double-tap and hold touchpad behavior

Peter Hutterer peter.hutterer at
Mon Aug 22 21:42:41 PDT 2011

On Mon, Aug 22, 2011 at 11:24:38PM -0500, Brandon Casey wrote:
> On Fri, Aug 19, 2011 at 1:15 AM, Peter Hutterer <peter.hutterer at>wrote:
> > On Wed, Aug 17, 2011 at 10:16:18PM -0500, Brandon Casey wrote:
> > > Please let me know if this is the wrong place to post this message.
> > >
> > > For a long time now I have been missing the old method that I used to use
> > to
> > > highlight text, drag-and-drop, and move windows around.  I used to be
> > able
> > > to produce a button press-and-hold by performing a double-tap and hold
> > (tap
> > > twice on touchpad, but leave the finger resting on the touchpad on the
> > > second tap).  But with recent distributions the last few years, that
> > doesn't
> > > work.  Now, it seems, you have to double-tap, hold, and drag.
> > >
> > > Is there any way to re-enable the old double-tap-and-hold instead of the
> > > double-tap-and-drag?
> >
> > this probably doesn't help but I've just tried it here and it worked fine.
> > you can disable it by unsetting the Synaptics Gestures property but it is
> > enabled by default.
> >
> So, when you double-tap-and-hold on a window title bar, without moving
> the mouse after the second tap (i.e. no "drag" gesture), your pointer grabs
> the title bar and the mouse icon changes to indicate that?

tbh, I can't tap without moving, my touchpad is too sensible. it
always moves by a few pixels at least.

> Just to make sure you understood me (and I you), when I do the
> above, nothing happens.  It doesn't even produce an event in xev.

if you're on the window bar, the event never goes to xev, it's captured by
the WM. try doing it _inside_ the xev window, that should show events.

> The double-tap-and-drag gesture does work, but for that one, you have
> to drag your finger after the second tap (touch-release-touch-drag).
>  The Synaptics Gestures property controls this feature.  If I disable it,
> then it disables double-tap-and-drag, but it doesn't enable
> double-tap-and-hold.  You then have to use the
> physical buttons.

I can't remember any changes to this extent going into the driver. maybe
it's a side-effect of other change but you'd have to look at the state
machine in the driver where exactly the problem is now.
> I would like to enable the tap-and-hold functionality, but I don't know
> how to get it.  Maybe there is an alternative touchpad driver other than
> the synaptics one?  If so, how do I disable the synaptics driver and just
> use the standard one?

there's only one touchpad driver.

> I'm using fedora-15, and fedora 13 before it.  What distribution are
> you using?

F15, but my X bits are the upstream ones.


More information about the xorg mailing list