Xorg - Buildroot distribution - chip XGI Volari z9s

Damien Borie dbe at terawatt.fr
Thu Mar 25 08:11:51 PDT 2010

Hello everybody.

This is my first message in this list, so forgive me if I'm not quite 

First, the situation.
We work on a panel PC, the Icop PDX-089T, which contains a graphic 
chipset XGI Volari Z9S, a screen of size 8'9, a touch screen, and some 
other things.
We have installed a Linux distribution, a customized one created with 
Buildroot. The aim is to execute three applications, and one of them is 
a graphic application (made with QT). So we need a nice displaying, with 
mode 1024x600x16.

Before that, we used a PDX-057T, which is exactly the same device but 
with a smaller screen (5'7). We used Framebuffer with Vesa driver and 
succeed to obtain the good resolution (640x480x16).
But the same Linux distribution on the PDX-089T doesn't offer a good 
resolution. The best is 800x600x8, and there is no mode with depth 16. 
We have concluded that there is a memory limit in Framebuffer which not 
allow depth of 16 with the same chip on a larger screen.

So we had to active Xorg in our distribution. After some epic battles, 
we succeeded in creating a new distribution with Buildroot with Xorg and 
the drivers XGI and SiS installed. Then we tried to set up and launch a 
X server, but for now without success.

The first try was with Xorg 1.5.3, XGI drivers 1.5.0, SiS drivers 
0.10.0, which were all include in Buildroot last release (2010.02).
The issues :
*Framebuffer + Vesa* : Max resolution : 800x600x8. No depth 16
*Xorg + XGI* : No apparent error, but black screen. Interrupt doesn't 
return to the console.
*Xorg + SiS* : No apparent error, but black screen. Interrupt allow to 
return to the console.
*Xorg + XGIZ* : We try to install several version on the XGIZ driver, 
which is provided by XGI (and some other providers like Icop). No one 
seems to correspond to Xorg version 1.5.3, and no one works.

After some search, we decided to try with the last snapshot of 
Buildroot, as a lot of X update have been made.
Second try : Xorg 1.7.1, XGI driver 1.5.1, SiS driver 0.10.2, included 
in the snapshot, and XGIZ driver 2.70.1201 provided by Icop support service.
*Framebuffer + Vesa *: Max resolution : 800x600x8. No depth 16
*Framebuffer + sisfb *: No display, black screen. Option problems? We 
didn't search any further...
*Xorg + XGI* : Load module failed with this error :
"LoadModule: Module xgi does not have a xgiModuleData data object."
I don't know where this error comes from.
*Xorg + SiS* : No apparent error, but black screen. Interrupt allow to 
return on the console.
*Xorg + XGIZ* : Load module failed with this error :
"dlopen: /usr/lib/xorg/modules/drivers/xgiz_drv.so: undefined symbol: 

We are searching for long days now, for no result. All these drivers 
should works and be compatible with the chip. But, as we're not at all 
specialist of Xorg, we must have missed something.

What I search here is :
- any suggestion about the errors when loading module for XGI and XGIZ 
- any idea about why SiS driver doesn't seems to fail but do not display 
- any others suggestion from anybody who has already use this chip and 
encounters some problems.
- any explanation about the apparent Framebuffer limit, as the provider 
confirm that 1024x600 resolution should be supported.
- any suggestion about the options to set in xorg.conf, as I tried many 
things but with no results, and without understand everything.
I have all the Xorg.0.log files saved if it's needed.

I'll try to debug the source code of the driver, but I don't know if I 
could find something. So before I post here, in the hope to obtain some 
informations by people more specialized.
Sorry for the very long message, and thank you for your time.

Best regards.

Damien Borie

64990 Villefranque

tel : +33 (0)5 59 44 26 08
fax : +33 (0)5 59 31 15 11 

More information about the xorg mailing list