where are header files?

tj 999alfred at comcast.net
Tue Mar 2 15:05:50 PST 2010

I am going to try to modify the xf86-inout-summa-1.2.0 to also work on 
my older Summagraphics Bitpad one. I am doing this using under a 
Slackware 13 distro. I ran ./configure and it didn't complain and 
created the make files. But, when I ruin make I get missing header 
files. Example:

xf86Summa.c:33:25: error: xf86Version.h: No such file or directory
xf86Summa.c:35:49: error: missing binary operator before token "("
xf86Summa.c:122:24: error: xf86Config.h: No such file or directory
xf86Summa.c:124:24: error: atKeynames.h: No such file or directory
xf86Summa.c:128:19: error: osdep.h: No such file or directory

I tried to locate these on my slackware system and distro DVD, but no 
luck. I went to http://xorg.freedesktop.org/releases/X11R6/ and 
downloaded the xc-1 tar and found these.
However, I found
xorg $ tar -tvaf xc-1.tar.gz | grep atKeynames
-r--r--r-- 11118/0       11891 1995-01-13 14:19 
-r--r--r-- 11118/0       10197 1994-02-22 09:24 
xorg $ tar -tvaf xc-1.tar.gz | grep osdep
-r--r--r-- 11118/0        8012 1994-04-17 19:56 xc/programs/xfs/os/osdep.h
-r--r--r-- 11118/0        8771 1994-04-17 20:27 

As can be seen there are two of each of these and are different sizes. 
Which would I need to use?

Where should the headers be placed for driver development?

Is there a tutorial or guide someplace for driver development?


More information about the xorg mailing list