Xdmx issues

Harm Nijveen harm.nijveen at wur.nl
Wed Jun 30 07:11:05 PDT 2010

The first issue is solved when I only enable Xinerama for Xdmx and not 
on the backend X servers.


Nijveen, Harm wrote:
> Hi,
> I am trying to get Xdmx working on a 12 screens/3machines setup and came across some problems.
> Using the "xorg-x11-server-extra" package in OpenSuse 11.3 RC1 (X11R7.5) I do get Xdmx running together with Gnome and using Xinerama. However, when a window is dragged across a screen boundary the window does not get redrawn (it turns grey), unless the screen boundary is between two screens attached to different PCs. Any ideas where to look for a solution? Is this a Xinerama problem?
> The right two colums of the 4x3 setup show strange distortions, like parts of windows from previous Xdmx sessions or a black and white diagonal banding pattern. It looks like uninitialized memory is being displayed. This already happens if I run gnome with Xdmx on one machine using four screens, but not when I run gnome directly with the local X server. How can I debug this further?
> Another issue involves a segfault of Xdmx when starting Glx programs, like glxgears, glxinfo etc.:
> Program received signal SIGSEGV, Segmentation fault.
> 0x00000000005abdb2 in __glXGetVisualConfigs (cl=0x9fbbf0, pc=0x9f57c0 "\214\016\002") at glxcmds.c:1546
> 1546        reply.numVisuals = pGlxScreen->numGLXVisuals;
> (gdb) bt
> #0  0x00000000005abdb2 in __glXGetVisualConfigs (cl=0x9fbbf0, pc=0x9f57c0 "\214\016\002") at glxcmds.c:1546
> #1  0x00000000005a50e7 in __glXDispatch (client=0x9f5420) at glxext.c:460
> #2  0x000000000053d7e6 in Dispatch () at dispatch.c:445
> #3  0x000000000052f03e in main (argc=7, argv=0x7fffffffe458, envp=0x7fffffffe498) at main.c:285
> (gdb) print pGlxScreen
> $1 = (__GLXscreenInfo *) 0x0
> It looks like a X_GLXGetVisualConfigs request is recieved and handled, but glxInitVisuals was never called and so  "pGlxScreen = &__glXActiveScreens[screen];" returns 0.
> Any ideas how to get around this? I really would like to be able run OpenGL applications using Xdmx and Chromium, but that is not possible right now.
> About the configuration:
> From the Xdmx logging:
> (II) dmx: Generation:         1                                                                          
> (II) dmx: DMX version:        1.2.20070424 (DMX Project)                                                 
> (II) dmx: DMX Build OS:       openSUSE (SUSE LINUX)                                                      
> (II) dmx: DMX Build Compiler: gcc 4.5.0                                                                  
> (II) dmx: DMX Execution OS:   Linux 2.6.34-9-desktop #1 SMP PREEMPT 2010-06-03 18:33:51 +0200          
> Vendor release:  10800000      
> Videocard: NVidia Quadro FX 4700 X2
> Driver: NVIDIA-Linux-x86_64-256.35
> Using TwinView
> Any help is appreciated.
> Cheers,
> Harm Nijveen
> _______________________________________________
> xorg at lists.freedesktop.org: X.Org support
> Archives: http://lists.freedesktop.org/archives/xorg
> Info: http://lists.freedesktop.org/mailman/listinfo/xorg
> Your subscription address: harm.nijveen at wur.nl

More information about the xorg mailing list