Xdmx -input device problem

Leif Bergerhoff leif.bergerhoff at student.tu-freiberg.de
Fri May 15 04:44:54 PDT 2009

Hello list,

since a couple of weeks I've been trying to get Xdmx working correctly. Almost 
everything works fine, but I recognize a strange behaviour regarding the 
input devices, especially my mouse:
I'm not able to move the cursor through all areas of the desktop.
The accessible area is limited to the upper left display and the one above it.
I could notice that on two different setups:

1. I'm using my laptop to connect to a PC with 4 monitors, so I'm able to move 
the cursor to access elements on monitors 1 and 2.

|   1    |   3    |
|   2    |   4    |

2. I'm using my laptop to connect to a PC with 6 monitors, still the same 
behaviour. The cursor can only be moved through the parts of the desktop 
displayed in monitor 1 and 2.

|   1    |   4    |
|   2    |   5    |
|   3    |   6    |

My intention was that Xdmx is choosing the wrong mouse driver, so I tried the 
command line option -input, but either I misunderstood Xdmx's manpage or sth. 
in Xdmx's code is broken, since Xdmx dosen't accept this and all I get is:

"(Fatal Error) dmx: Unknown input argument: ps2"

startx -- /usr/X11R7/bin/Xdmx :1 -configfile /home/leif/doc/xsite/xdmx.conf -config 
keller -input kbd,ps2)

I've tried to connect via another Pc than my laptop and Xdmx works fine 
there - without these mouse problems.

I'm using Xdmx from xorg-server-


More information about the xorg mailing list