[intel 845G/GL] Status of xorg, xf86-video-intel, etc on 845

dolphinling lists at dolphinling.net
Thu Feb 19 11:13:48 PST 2009

I've been trying to run the latest xorg components on an i845 for a while now,
and I haven't found a good set of component versions + configurations that works
well. Here's info on the most recent release + current git versions of stuff. If
there's anywhere else I should put this (e.g. individual problems to bugzilla)
just say so.

For future reference, I run gentoo, and all packages are from either gentoo or
the gentoo x11 overlay, except for the kernel, which is either from kernel.org
or one of the drm-intel kernels.

All the Xorg.0.logs from this are available at http://dolphinling.net/xorglogs/

I would be very happy to help out with any testing/etc for making these work, 
subject to availability (which is more or less entirely random).


Components used:
xf86-video-intel-2.6.1 and current git
libdrm-2.4.4 with x-v-i-2.6.1 and libdrm current git with x-v-i git
kernel-2.6.28-drm-intel from intellinuxgraphics.org and 2.6.29-rc5


		noaccel: works, vt switch problem* + puts monitor in unusable
		exa: server does not start (bug 19336)
		uxa: server starts, missing some fonts, some areas of screen
		     just grey, can't log in
		noconf: exa
		noaccel: works, vt switch problem* + puts monitor in unusable
		         state (no memory leak)
		exa: fonts too small on login screen, wrong resolution, some
		     areas not painting, no cursor, vt switch problem,
		     glxgears < 5 fps
		uxa: memory leak*, (there is a cursor)
		noaccel: login screen displays, buttons broken, can't log in,
		         no cursor
		exa: fonts too small/missing/too large/corrupted; wrong
		     resolution, no cursor, things not drawing sometimes, can
		     log in
		uxa: same as 2.6.28-drm-intel (maybe even pixel-for-pixel)
		noconf: fonts too small/missing/corrupted, textarea black,
		        can't log in

		noaccel: no cursor, glxgears broken, memory leak*, vt switch
		exa: fonts too small, no cursor, wrong resolution, some areas
		     do not paint, glxgears < 10fps, memory leak very slow?*
		     vt switch problem*
		uxa: same as noaccel

* memory leak: memory is used used up very fast, especially with firefox. Can
                make computer unusable in < 10 seconds if I'm trying, if I try
	       to keep it working I can use it for maybe a few minutes.
	       free reports almost all the memory as "cached". Sometimes, top
	       reported X as using > 1G of virtual memory (only virtual);
	       other times it did not. Starts swapping when memory full, but
	       nothing ever crashed from OOM.

* vt switch problem: when attempted to switch vts, the screen did not update,
          but the switch worked. I could log in and make mplayer play music
	 blindly. In the nicer incarnation, a few pixels would change but
	 mostly whatever was displayed would stay. In the worse incarnation,
	 the screen would go black and my monitor's power light would start
	 blinking orange, and the only way to get things to display would be
	 to turn the monitor off, switch back to X, then turn the monitor on
	 again. If turned back on while on a non-X vt it would just keep
	 blinking orange.


More information about the xorg mailing list