How to troubleshoot intel 3D performance?

Alex Bennee kernel-hacker at
Mon Feb 16 09:33:23 PST 2009


I recently switched on Compiz on my desktop machine to see what the
fuss was about. Running on the stable Gentoo X and intel drivers more
or less everything worked well. The benchmark tool reported 120fps on
most static screens and seemed pretty happy with most of the effects.
However video playback was jerky especially while zoomed to
full-screen. After a little tinkering with texture sizes and
attempting to enable XvMC and realised I needed to be running more
recent drivers. So I upgraded X to:

*  x11-drivers/xf86-video-intel
      Latest version available: 2.6.1
      Latest version installed: 2.6.1

*  x11-base/xorg-server
      Latest version available: 1.5.3-r2
      Latest version installed: 1.5.3-r2

After rebuilding all the constituent packages I ended up with a Compiz
setup that was reporting 25fps if I was lucky and reduced to 8/9fps
when displaying full screen terminals. Curiously video playback seems
smoother running on 2.6.29-rc5 kernel although just as jerkey on

I'm at a loss to where to begin on the troubleshooting. Attached is my
Xorg.log which has a little W/E noise in it but nothing that means
anything to me. I've tried UXA (instead of EXA) and various Buffering
flags but nothing seems to help.

Suggestions welcome.

Alex, homepage:
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Xorg.0.log
Type: application/octet-stream
Size: 33778 bytes
Desc: not available
URL: <>

More information about the xorg mailing list