Multiseat with VGAArbiter on 2 Radeon cards - found KMS

Steffen Schaumburg steffen at
Tue Dec 22 09:49:26 PST 2009

Ok I just realised that KMS has to be activated in staging. So I tried
that now, but without success :(

So I tried 3 kernel configs now.

In common they have:
Kernel 2.6.32 (gentoo-sources)
xorg-server 1.7.3
using the xorg radeon/ati driver
identical xorg.conf and kdmrc (attached)
Both boot in text mode fine

The differences (all configs are attached):
1) had KMS and DRM off
2) DRM on
3) DRM and KMS on

Now the results vary quite a bit.

All of them start booting in textmode on the monitor connected to the
primary graphics card.
1 and 2 continue to boot and allow me to do a text login. However with
KMS on by default the monitor suddenly goes black (but not into standby)
during boot, I think when it starts loading the modules but I'm not
quite sure, it's hard to tell because the messages come so fast at that
point. However I can still login blindly. If I try to start KDM nothing
changes on the screens.

As said 1 and 2 let me login normally so here's what happens from then:
With the kernel without DRM I can start KDM and it displays on the
screen connected to the secondary card (note: this is the first entry in
kdmrc). I can then login and work on that monitor just fine, in fact I'm
writing this email from it.
With the kernel with DRM it's not so good. The second monitor turns on
but both just go blank and stay blank.

Note that in all of the scenarios I can always cause an orderly shutdown
by pressing the power button.

Any ideas?

Thanks, Steffen

> Okay I tried turning off arbiter by just editing .config
> ("CONFIG_VGA_ARB=n") but when I type my usual "make && make
> modules_install" it changes it back automatically. I tried rebooting
> into this new kernel anyways but it continues to load arbiter as
> evidenced in the boot messages and as expected it still doesn't work. I
> haven't been able to turn off arbiter in make menuconfig as its
> automatically turned on by other options so it doesn't even show up in
> there.
> Does anyone have any ideas what I'm doing? Or is anyone out here running
> a multiseat setup with radeon cards? I'd be very very grateful if you
> could send me your xorg.conf, ?dm config (e.g.
> /usr/share/config/kdm/kdmrc), the version numbers of your xorg-server,
> type&version of driver (at this stage I'd even try the proprietary
> drivers) and what you use to launch X as well as its version.
> So any tips, no matter how unlikely you think they are to work, would be
> greatly appreciated.
> TIA,
> Steffen
>> Okay I figured I might as well try Tiago's idea. I'm not sure what if I
>> used the right command but here's what I tried:
>> xterm -display :1 -e bash &
>> xterm -display :1.0 -e bash &
>> xterm -display localhost:1 -e bash &
>> xterm -display localhost:1.0 -e bash &
>> I tried all four as both root and user and they all fail saying "Can't
>> open display: localhost:1.0" (with different display depending on what I
>> used).
>> Thanks, Steffen
>> Steffen Schaumburg wrote:
>>> Hi,
>>> thanks both of you for your replies - I'm going to try the KMS method
>>> first. Now the problem is I can't turn off Arbiter in the kernel, make
>>> menuconfig can find it with the search, but the option isn't in the
>>> menu. Is there a boot option to force off arbiter (or, alternatively, to
>>> force on KMS which would turn off arbiter by necessity?)? I checked the
>>> docs at
>>> but can't see anything. Or should I just manually edit the .config file
>>> - I'm inclined to trust menuconfig to not be displaying the option for a
>>> reason, or am I giving it too much credit? Any pointers would be
>>> appreciated.
>>> Thanks, Steffen
>>>> Multicard and multiseat for radeon doesn't need vgaarb; use KMS
>>>> instead and your cards will both come up at boot.
>>>> Posting from a mobile, pardon my terseness. ~ C.
>>>>> On Dec 5, 2009 9:30 AM, "Tiago Vignatti" <tiago.vignatti at
>>>>> <mailto:tiago.vignatti at>> wrote:
>>>>> On Fri, Dec 04, 2009 at 09:00:19PM +0100, ext Steffen Schaumburg
>>>>> wrote: > Hi everyone, > I'm trying ...
>>>>> yes. And the log says you're indeed using it.
>>>>>> The current status of my work is: > >From pressing the power button
>>>>> to kdm loading it displays i...
>>>>> humm, seems not issue with vga arbitration. I'd guess maybe missed mode
>>>>> setting. Try to start an app on the monitor black and see if
>>>>> connects. If this
>>>>> succeeds then the arbiter is doing its job okay.  
> _______________________________________________
> xorg mailing list
> xorg at

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: config-2.6.32-gentoo-r0-01-without-drm-without-kms
URL: <>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: config-2.6.32-gentoo-r0-02-with-drm-without-kms
URL: <>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: config-2.6.32-gentoo-r0-03-with-drm-with-kms
URL: <>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: kdmrc
URL: <>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: xorg.conf
URL: <>

More information about the xorg mailing list