radeonhd blank screens

Justin P. Mattock justinmattock at gmail.com
Wed Dec 9 01:18:09 PST 2009

On 12/09/09 01:08, Goran Gajic wrote:
> On Mon, 7 Dec 2009, Justin P. Mattock wrote:
>> On 12/07/09 09:35, Goran Gajic wrote:
>>> For some reason all reports regarding problems with ATI 48xx seems to be
>>> ignored. I also have ATI, but 4870 chipset and the only solution I have
>>> come up to was switching to xorg-server 1.4.2. Issue is not OS related
>>> behaviour is same under Linux and FreeBSD.
>>> gg.
>>> _______________________________________________
>>> xorg mailing list
>>> xorg at lists.freedesktop.org
>>> http://lists.freedesktop.org/mailman/listinfo/xorg
>> latest git Xserver seems to be o.k. over here with
>> a macbook(x1600). I also am running the latest kernel from
>> git as well. In your case not sure what kernel your
>> running, but over here with the latest there's some new kms
>> stuff that seems to be added.(maybe this is the problem!);
>> hope this helps.
>> Justin P. Mattock
> As I`m using FreeBSD and Linux Slackware - I have tried with vesa,
> radeon, radeonhd - same results - black screen - although I'm able to
> switch from it with ctrl+alt+Fx. Card I'm using is Radeon 4870, with two
> DVI outputs (DVI and HDMI).
> Regards,
> gg.

man.. thats not good.
heres what I use to debug startx
(if you don't have already);
sh -x/usr/bin/startx &>startx.log
taken from:

As for what might be happening, tough to say, i.g.
was hitting some startx issue over here,
ended up uninstalling everything(headers/libs),
and then using the blfs tutorial installed as listed,
then vesa worked as well as nvidia.

as for debugging if you have ohci_dma1394=early
then you can get an idea as well, or ssh into the machine
before startx to grab the logs.

Justin P. Mattock

More information about the xorg mailing list