xorg, Xvfb, ImageMagick - then beat your head against your desk!

Vector Thorn vector.thorn at gmail.com
Thu Dec 3 14:18:37 PST 2009

Well i don't see anything in my configs about a chroot, only a  home
directory for apache (/etc/httpd) and a working directory (/var/www); but i
tried what you said anyway and it didn't work. I also tried setting the
owner and group to "root" (because i've seen that stated in NUMEROUS threads
in google results) and that didn't work either. Just for the heck of it, i
also tried creating a /home/apache folder, in case xorg was trying to
execute and and store in the typical fashion, which did no good. I also
created a /etc/httpd/tmp/.X11-unix, which also did not work.

I'm stumped. But it seems that if the case were that apache was chrooted,
then i agree that it should be in your specified location (which was made
evident by missing gnome folder errors for that directory).

Ok, HERE is what i am still interested in, with these results:
Apache DOES launch Xorg,
Apache does NOT launch Firefox,
Apache DOES take a screenshot (of an empty x background).

So, somewhere in the middle is where the error lies. It seems that the error
i stated previously is NOT preventing apache from launching Xvfb or import
(Image Magick), but yet it IS preventing firefox from launching. I know that
FF is tied in closely with Gnome (FF is GTK, right?), so, i just wonder if
there is something else that i can try in FF's place........... but it would
also have to be independent of KDE. Is there a generic X-browser (sorry, i'm
an FF fanboy, so i don't know)?


On Thu, Dec 3, 2009 at 10:03 AM, Adam Jackson <ajax at nwnk.net> wrote:

> On Wed, 2009-12-02 at 17:17 -0500, Vector Thorn wrote:
> > [^v^] cat /var/log/httpd/error_log | tail
> > xauth:  creating new authority file /tmp/xvfb_1_at_a_time
> > _XSERVTransmkdir: ERROR: (l)stat failed for /tmp/.X11-unix (13)
> > _XSERVTransSocketUNIXCreateListener: mkdir(/tmp/.X11-unix) failed,
> > errno = 13
> > _XSERVTransMakeAllCOTSServerListeners: failed to create listener for
> > unix
> > Xlib:  extension "RANDR" missing on display ":66.0".
> > firefox: no process killed
> >
> > I'm not sure why it's trying to create that directory when it is
> > already there; furthermore, why it is trying to create it when run by
> > APACHE, but not when run by a USER...
> If I had to guess, you're running apache in a chroot, which means you
> need to precreate /tmp/.X11-unix in the chroot, which would probably
> be /var/www/tmp/.X11-unix.
> - ajax

Vector Thorn, Ionisis


All websites are under development
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.x.org/archives/xorg/attachments/20091203/b32ba88a/attachment.html>

More information about the xorg mailing list