X-Server 1.5.0 very sluggish

Owen Taylor otaylor at redhat.com
Mon Sep 15 09:31:33 PDT 2008

On Sun, 2008-09-14 at 12:42 -0500, Markus Strobl wrote:
> Hi,
> Tried X-Server-1.5.0 yesterday with the Radeon driver. It was extremely 
> sluggish in that after something was clicked it would take 2-3 seconds 
> before X did anything. Even hovering over window menus the highlighted 
> choice trailed behind the mouse pointer.
> Scrolling in a Firefox window was normal, but changing tabs had a 2-3 
> second delay. Minimizing/maximizing windows also had the delay. Typing 
> in a console window had no delay.
> Glxinfo reported DRI was working. Glxgears gave normal results. I tried 
> both XAA and EXA (no difference in performance).
> X logfile had nothing exciting.
> This morning I went back to 1.4.2 and everything is back to normal.

I don't have any immediate ideas, but I wanted to throw in the data
point that I also seem to see a sudden slowness on r300+EXA moving from
1.4.99 snapshot from July 2 (current F9 packages) to 1.5.0. Somewhat
similar to what you describe, though not nearly as extreme. (Some
windows take a couple of seconds to repaint, but menus are normal.) 

This is leaving the radeon driver, mesa, etc, unchanged, and only
upgrading the X server.

The slowness seems to be triggered by rendering UI elements in the GTK+
theme I'm using (Clearlooks, AFAIK) ... so it would be some sort of
problem with Render acceleration of gradients, masks, or similar. 

Looking at sysprof output, most of the time during sluggish redrawing
is spent migrating pixmaps from video memory into system memory inside a
Composite operation, so it appears that for some reason, software
fallbacks are being triggered. The sysprof output, unfortunately doesn't
have enough detail to be able to tell why that is happening.

- Owen

More information about the xorg mailing list