RRPropertyValuePtr compile problem for git ATI driver

Michael Shell list1 at michaelshell.org
Fri Jun 6 06:46:59 PDT 2008

I've been trying to compile the ATI driver (xf86-video-ati) from git
(using gcc 4.1.2 on a ix86 Linux box) against an Xserver 1.4
(xorg-server-1.4) source tree. Configure indicates that
"X server >= 1.3" should be acceptable. I haven't tried
it with xorg-server from git ... yet.

However, when compiling it I run into:

make[2]: Entering directory `/home/lfs/sources/Xorg_new/UPZ/xf86-video-ati-snapshot-2008-06-05/src'
/bin/sh ../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I.. -I./AtomBios/includes  -Wall -I/usr/X11/include/xorg -I/usr/X11/include   -I/usr/X11/include -I/usr/X11/include/drm -I/usr/X11/include/X11/dri   -DXF86_MODES_RENAME -I../src -I../src/modes -I../src/parser -DDISABLE_EASF -DENABLE_ALL_SERVICE_FUNCTIONS -DATOM_BIOS -DATOM_BIOS_PARSER -DDRIVER_PARSER -g -O2 -MT radeon_output.lo -MD -MP -MF .deps/radeon_output.Tpo -c -o radeon_output.lo radeon_output.c
 gcc -DHAVE_CONFIG_H -I. -I.. -I./AtomBios/includes -Wall -I/usr/X11/include/xorg -I/usr/X11/include -I/usr/X11/include -I/usr/X11/include/drm -I/usr/X11/include/X11/dri -DXF86_MODES_RENAME -I../src -I../src/modes -I../src/parser -DDISABLE_EASF -DENABLE_ALL_SERVICE_FUNCTIONS -DATOM_BIOS -DATOM_BIOS_PARSER -DDRIVER_PARSER -g -O2 -MT radeon_output.lo -MD -MP -MF .deps/radeon_output.Tpo -c radeon_output.c  -fPIC -DPIC -o .libs/radeon_output.o
radeon_output.c: In function 'radeon_create_resources':
radeon_output.c:1121: warning: implicit declaration of function 'RRConfigureOutputProperty'
radeon_output.c:1130: warning: implicit declaration of function 'RRChangeOutputProperty'
radeon_output.c: At top level:
radeon_output.c:1389: error: expected declaration specifiers or '...' before 'RRPropertyValuePtr'
radeon_output.c: In function 'radeon_set_property':
radeon_output.c:1397: error: 'value' undeclared (first use in this function)
radeon_output.c:1397: error: (Each undeclared identifier is reported only once
radeon_output.c:1397: error: for each function it appears in.)
radeon_output.c: At top level:
radeon_output.c:1590: error: unknown field 'set_property' specified in initializer
radeon_output.c:1590: warning: initialization from incompatible pointer type

Searching for a similar case, I found one with respect to the Intel
driver in early 2007:


I assume that was fixed, but the cause of the problem and its solution
were never posted.

  Thanks in advance for any help,

  Mike Shell

More information about the xorg mailing list