X.org crashes on current branches

Tobias Hain tobias.hain at gmx.de
Thu Dec 18 04:37:00 PST 2008


chipset: GM965
kernel: (vanilla) 2.6.28-rc8, (drm-intel-next) of Eric's 2.6.28-rc8
xserver: server-1.6-branch
libdrm: master
mesa: master and intel-2008-q4
xf86-video-intel: xf86-video-intel-2.6-branch

remaining components: Kubuntu 8.10

I'm facing X.org crashes when launching X with all of the above:

0: /opt/gfx-test/bin/Xorg(xorg_backtrace+0x3b) [0x81323fb]
1: /opt/gfx-test/bin/Xorg(xf86SigHandler+0x51) [0x80b82a1]
2: [0xb7f9b400]
3: /opt/gfx-test/lib/dri/i965_dri.so [0xa75c6a08]
4: /opt/gfx-test/lib/dri/i965_dri.so(intelTexImage2D+0x7e) [0xa75c712e]
5: /opt/gfx-test/lib/dri/i965_dri.so(_mesa_TexImage2D+0x2aa) [0xa76647ea]
6: /opt/gfx-test/lib/xorg/modules/extensions//libglx.so [0xb7a40278]
7: /opt/gfx-test/lib/xorg/modules/extensions//libglx.so [0xb7a6a5fb]
8: /opt/gfx-test/lib/xorg/modules/extensions//libglx.so [0xb7a6eb8a]
9: /opt/gfx-test/bin/Xorg(Dispatch+0x33f) [0x808cc6f]
10: /opt/gfx-test/bin/Xorg(main+0x3bd) [0x807192d]
11: /lib/libc.so.6(__libc_start_main+0xe5) [0xb7ad3685]
12: /opt/gfx-test/bin/Xorg [0x8070de1]

Fatal server error:
Caught signal 11.  Server aborting

It's always the same crash and related to 3D compositing manager loading I
guess. I tried some permutations of the above branches, but none worked.
Always the same crash that I didn't have before updating the branches. I've
been tracking intel driver development for a while, but not on a regular
basis. I think I updated branches one month old and before that everything
worked fine. xorg.conf doesn't contain anything special.

It's KDE 4.1 compositing manager. Haven't tried anything else yet. Hope it
sounds familiar to some.


More information about the xorg mailing list