[intel gm965] kernel panic while suspending to disk

Stefano Avallone stavallo at unina.it
Wed Dec 10 10:14:10 PST 2008

Hi lists,

I am experiencing a kernel panic while suspending to disk my sony vaio laptop 
equipped with an Intel GM965 chipset. The call trace is as follows:

Call Trace:
[<c0155db9>] count_highmem_pages+0x49/0xa0
[<c0153975>] swsusp_shrink_memory+0x35/0x200
[<c01542d2>] hibernation_snapshot+0x12/0x200
[<c01574ad>] snapshot_ioctl+0x10d/0x580
[<c012c0c1>] release_console_sem+0x1a1/0x1f0
[<c01573a0>] snapshot_ioctl+0x0/0x580
[<c019ed0b>] vfs_ioctl+0x2b/0x90
[<c01224ae>] __wake_up+0x3e/0x60
[<c019ef07>] do_vfs_ioctl+0x67/0x4d0
[<c0267474>] tty_ldisc_deref+0x44/0x70
[<c0261db4>] tty_write+0x1a4/0x1f0
[<c0192a3a>] vfs_write+0x10a/0x140
[<c019f3f4>] sys_ioctl+0x84/0x90
[<c0103e09>] sysenter_do_call+0x12/0x21
[<c0320000>] quirk_e100_interrupt+0xdc/0x1c9
Code: ...
EIP: [<c016f76a>] mark_free_pages+0x11a/0x160 SS:ESP 0068:f4fd3e58

The kernel panic occurred while running a kernel 2.6.28-rc7 from branch "drm-
fixes" and the git master of drm, mesa, xserver, xf86-video-intel etc. as of 

Quite surprising (to me, at least) is that while running the same kernel and 
the xserver etc. from debian experimental (xserver 1.5.3, mesa 7.2, libdrm 
2.4.1, intel 2D driver 2.5.1), suspend to disk works (but some problems while 

So, looks like the problem is not in the particular kernel version. Actually, 
I started noticing such kernel panics a couple of weeks ago when I updated my 
local git repositories and recompiled all the stuff. Since then, I have been 
no longer able to suspend the laptop with the stuff compiled from git master 
(also tried with DRI2 enabled).  I tried several kernel versions, disabling 
PAT and MSI in the kernel, etc. with no luck.

I can provide more info if needed and available to git-bisect. Any suggestion?


More information about the xorg mailing list