Trying to use Radeon driver on Apple eMac

Joseph Adams joeyadams3.14159 at
Mon Dec 8 22:58:19 PST 2008

I tried every single combination of ConnectorTable entry you
suggested, but none of them seemed to have any effect.  However, I did
try all the MacModel s.  I found that for every powerbook-* option,
the screen would flash the correct image, then would go to black right
away (when the server is started or VT-switched to).  The image looked
fine on the bottom half, but the top half was covered in trash.

The flash I'm referring to shows the image at 1024x768, then goes to
black in about a fifth of a second.  The image pulses in an expanding
motion (this is a CRT monitor) then immediately blanks with no monitor

I tried running glxgears in the few-millisecond interval, but that
requires me killing it through SSH.  It displays the correct image,

I took a screenshot with xwd, and the screenshot is fine.  The image
is 1280x1024, and the GNOME panels line up to 1024x768.  The 1024x768
is the resolution I see in that quick flash.

In these attempts, I get the following xrandr output:
Screen 0: minimum 320 x 200, current 1280 x 960, maximum 2048 x 1200
LVDS connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0*+   60.0
   800x600        60.3
   640x480        59.9
DVI-0 connected 1280x960+0+0 (normal left inverted right x axis y
axis) 0mm x 0mm
   1280x960       60.0*+   59.9
   1024x768       60.0
   800x600        60.3
   640x480        59.9
S-video disconnected (normal left inverted right x axis y axis)

I still cannot change Xorg modes through xrandr due to the same error messages.

I played around with the Radeon driver source by adding an eMac entry
but essentially copying it from the PowerBook stuff.  I have made a
rather makeshift patch against xf86-video-ati-6.9.0 which has some
unneeded garbage in it (it can also be downloaded at ), but it might be
helpful.  With that patch and with that driver, I get the flash effect
described above without any special xorg.conf options, and my
Xorg.0.log mentions eMac.

My cat /proc/cpuinfo is:
processor	: 0
cpu		: 7455, altivec supported
clock		: 999.999997MHz
revision	: 0.3 (pvr 8001 0303)
bogomips	: 66.04
timebase	: 33179574
platform	: PowerMac
model		: PowerMac4,4
machine		: PowerMac4,4
motherboard	: PowerMac4,4 MacRISC2 MacRISC Power Macintosh
detected as	: 80 (eMac)
pmac flags	: 00000010
L2 cache	: 256K unified
pmac-generation	: NewWorld

(hehehe, not quite a gigahertz)

Anyway, what might be causing the image to have garbage and to
immediately disappear?  Thanks.

On Mon, Dec 8, 2008 at 6:22 PM, Alex Deucher <alexdeucher at> wrote:
> On Mon, Dec 8, 2008 at 2:01 PM, Joseph Adams <joeyadams3.14159 at> wrote:
>> I'm struggling to get the Radeon driver to work on my eMac G4's Radeon
>> 7500 card (the fbdev driver works fine at 1024x768 with no
>> acceleration).  On both Fedora 8 and Fedora 10 with default xorg.conf,
>> the screen is blank (the CRT doesn't glow or anything).  I have a CRT
>> monitor that supports up to 1280x960.  The eMac also has a video out
>> port.  I suspect that video may show up on an external monitor, but I
>> can't test that until my adapter arrives.
> Mac cards don't have a connector table and are always wired up
> strangely.  We'll probably need to add a custom connector table for
> your card as it's currently falling back to the default which is
> probably wrong for your card.  Can you send me the output of
> /proc/cpuinfo?
> Try the following option and let me know which combinations work:
> Option "ConnectorTable" "i,1,0,1,j,2,0,1"
> where i and j are one of the following:
> 96, 100, 104, or 108
> and i != j.
> i and j specify the gpio line used for ddc, so when you get the right
> combination, you should see the driver picking up an edid if your
> monitor supports it.  If the built in monitor doesn't supply an edid,
> we'll have to add a quirk for that as well.
> Alex

More information about the xorg mailing list