Fatal server error: could not open default font 'fixed'

Marcos Cunha kinhocunha at gmail.com
Mon Dec 8 21:18:01 PST 2008

Hi Folks...

I´ve been searching along the mailling lists a solution for this damn

The server is the full 7.4 release of Xorg, compiled under a LFS/VMware.

I tried to use mkfontdir and mkfontscale under .../fonts/misc but it still
making a '0' file content =/

And also, symlinking with another fonts dir, from my old Xorg (7.3), but it
still not working...

The console blanks for a while like it being work, but them crashes...

Follows the screen.

root at lfs:~# Xorg
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/lfs:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X.Org X Server 1.5.1
Release Date: 23 September 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux i686
Current Operating System: Linux lfs #2 Thu Nov 27 01:52:18 BRT 2008
Build Date: 09 December 2008  01:14:42AM

        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Dec  9 02:11:25 2008
(==) Using config file: "/etc/X11/xorg.conf"

Fatal server error:
could not open default font 'fixed'
root at lfs:~#

Marcos S Cunha
Ciência da Computação, Universidade Salvador
Programador e Webdesigner - Freelancer

MSN e Talk: kinhocunha at gmail.com
Cel.: +55 71 8135 8340

"Hackerism exploits everything."
Linux User # 434123
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.x.org/archives/xorg/attachments/20081209/d07568c7/attachment.html>

More information about the xorg mailing list