X Hangs at "Initializing int10"

Alex Villací­s Lasso a_villacis at palosanto.com
Tue Dec 2 09:34:39 PST 2008

Timothy S. Nelson escribió:
>     Hi all. I'm upgrading from Fedora 6 to Fedora 10. I did a clean 
> install of Fedora 10 and then, as the default X config didn't work, I 
> copied across my old xorg.conf file. Naturally I had to comment out a 
> few lines in that file.
>     Now a word on my setup. I have two screens, one hanging off an 
> nVidia card, and the other on a SiS card. Both of them work just fine 
> under Fedora 6.
>     Anyway, after I did the steps above, I found it didn't work, so 
> I've been trying one screen at a time. The SiS one works (unless I 
> install the proprietary nVidia driver, so I removed that). The nVidia 
> one doesn't work. I've tried the nv driver, the fbdev driver, and the 
> vesa driver, all of which failed, although not always with the same 
> error message. As nv is the one that worked with Fedora 6, that's the 
> way I'd prefer to go (because it should be possible), but I'm open to 
> other solutions.
>     When I try to use the nv driver, the console appears to be hung, 
> but it's still possible to ssh into the machine. The last entry in the 
> log read as follows:
I have a similar problem on my setup, but I am not trying to set up a 
multihead configuration. Rather, I wanted to start up a secondary video 
card in order to write a proper driver for it.

My primary chipset is a ProSavageDDR-K (handled by savage_drv.so) at 
PCI:1:0:0. As an exercise, I want to write a driver for an Oak Spitfire 
OTI64111 PCI video card, which is plugged on the same machine that has 
the savage chipset. The oti64111 card (at PCI:0:9:0) can be handled 
correctly with the vesa driver, and I have been using it to set up the 
card so I can peek into the graphics registers. In Fedora 8, I used the 
configuration file attached to this message in order to initialize the 
oti64111. This had the effect of blanking the screen attached to the 
savage chipset, and then booting the oak64111 BIOS and showing the 
familiar X cursor with the patterned background. Although a little 
problematic, I could switch back and forth between the two running X 

Under Fedora 10, an attempt to use the same method results in a hung 
machine. Now I have to reboot and select the BIOS option "Primary 
graphics card: (PCI/AGP)" and select AGP for the savage chipset (the 
normal setting) or PCI for the oak64111. Maybe this is of some help in 
solving the problem.

perl -e '$x=2.4;print sprintf("%.0f + %.0f = %.0f\n",$x,$x,$x+$x);'

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: xorg-test.conf
URL: <http://lists.x.org/archives/xorg/attachments/20081202/cb4d4e85/attachment.ksh>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Xorg.1.0.log
Type: text/x-log
Size: 5460 bytes
Desc: not available
URL: <http://lists.x.org/archives/xorg/attachments/20081202/cb4d4e85/attachment.bin>

More information about the xorg mailing list