X Hangs at "Initializing int10"

Timothy S. Nelson wayland at wayland.id.au
Tue Dec 2 02:10:53 PST 2008

On Tue, 2 Dec 2008, Matthieu Herrb wrote:

> Timothy S. Nelson wrote:
>>     Hi all. I'm upgrading from Fedora 6 to Fedora 10. I did a clean
>> install of Fedora 10 and then, as the default X config didn't work, I
>> copied across my old xorg.conf file. Naturally I had to comment out a
>> few lines in that file.
>>     Now a word on my setup. I have two screens, one hanging off an
>> nVidia card, and the other on a SiS card. Both of them work just fine
>> under Fedora 6.
> Most of the setups with 2 graphics cards are broken in xserver 1.5.x.

 	Thanks! (no sarcasm; now I can stop banging my head against a wall :) 

>>     Anyway, after I did the steps above, I found it didn't work, so I've
>> been trying one screen at a time. The SiS one works (unless I install
>> the proprietary nVidia driver, so I removed that). The nVidia one
>> doesn't work. I've tried the nv driver, the fbdev driver, and the vesa
>> driver, all of which failed, although not always with the same error
>> message. As nv is the one that worked with Fedora 6, that's the way I'd
>> prefer to go (because it should be possible), but I'm open to other
>> solutions.
>>     When I try to use the nv driver, the console appears to be hung, but
>> it's still possible to ssh into the machine. The last entry in the log
>> read as follows:
>> ------------------------------------------------------------
>> (II) Loading /usr/lib/xorg/modules//libint10.so
>> (II) Module int10: vendor="X.Org Foundation"
>>         compiled for 1.5.3, module version = 1.0.0
>>         ABI class: X.Org Video Driver, version 4.1
>> (II) NV(0): Initializing int10
> Did you remove the SiS card, or make it inactive in the BIOS in some way
> before trying that, or is it still there as primary card?

 	Nah, still there as primary.  All I was trying to do was ensure my 
configuration wasn't causing the problem :).

> This is generally caused by the pci_device_read_rom() function in
> libpciaccess returning wrong data, probably because ROM and memory
> access to the secondary card were not enabled correctly before accessing
> it.

 	In my case, this probably goes through to 
pci_device_linux_sysfs_read_rom as I'm on a Linux box.  This brings me to some 
1.	Is there a function I could call in libpciaccess that would output
 	stuff somewhere useful, preferably Xorg.0.log or whatever? 
2.	Where's the code that enables ROM and memory access?  How do I tell
 	when they're enabled properly.

 	Feel free to refer me to doco for either of the above.

> The int10 code is then looping endlessly in a maze of 0xff.

 	I presume the ff is a parameter passed to the int10 call?

 	Thanks again :).

| Name: Tim Nelson                 | Because the Creator is,        |
| E-mail: wayland at wayland.id.au    | I am                           |

Version 3.12
GCS d+++ s+: a- C++$ U+++$ P+++$ L+++ E- W+ N+ w--- V- 
PE(+) Y+>++ PGP->+++ R(+) !tv b++ DI++++ D G+ e++>++++ h! y-

More information about the xorg mailing list