X Hangs at "Initializing int10"

Matthieu Herrb matthieu.herrb at laas.fr
Mon Dec 1 22:33:57 PST 2008

Timothy S. Nelson wrote:
>     Hi all. I'm upgrading from Fedora 6 to Fedora 10. I did a clean
> install of Fedora 10 and then, as the default X config didn't work, I
> copied across my old xorg.conf file. Naturally I had to comment out a
> few lines in that file.
>     Now a word on my setup. I have two screens, one hanging off an
> nVidia card, and the other on a SiS card. Both of them work just fine
> under Fedora 6.

Most of the setups with 2 graphics cards are broken in xserver 1.5.x.

>     Anyway, after I did the steps above, I found it didn't work, so I've
> been trying one screen at a time. The SiS one works (unless I install
> the proprietary nVidia driver, so I removed that). The nVidia one
> doesn't work. I've tried the nv driver, the fbdev driver, and the vesa
> driver, all of which failed, although not always with the same error
> message. As nv is the one that worked with Fedora 6, that's the way I'd
> prefer to go (because it should be possible), but I'm open to other
> solutions.
>     When I try to use the nv driver, the console appears to be hung, but
> it's still possible to ssh into the machine. The last entry in the log
> read as follows:
> ------------------------------------------------------------
> (II) Loading /usr/lib/xorg/modules//libint10.so
> (II) Module int10: vendor="X.Org Foundation"
>         compiled for 1.5.3, module version = 1.0.0
>         ABI class: X.Org Video Driver, version 4.1
> (II) NV(0): Initializing int10

Did you remove the SiS card, or make it inactive in the BIOS in some way
before trying that, or is it still there as primary card?

This is generally caused by the pci_device_read_rom() function in
libpciaccess returning wrong data, probably because ROM and memory
access to the secondary card were not enabled correctly before accessing

The int10 code is then looping endlessly in a maze of 0xff.

> ------------------------------------------------------------
>     The last line you see is the last line in the file. I tried the
> NoInt10 option, and then it seemed to get a lot further, but eventually
> failed with "Fatal server error: AddScreen/ScreenInit failed for driver
> 0".  The vesa driver failed at the same point.
>     I'll attach my xorg.conf and my X.0.log; any help would be appreciated.

I'm not sure if Keith is planning to have this fixed in xserver 1.6.

Matthieu Herrb

More information about the xorg mailing list