Questions on Intel i915 chipset (performance, gallium)

Tobias Jakobi liquid.acid at
Sun Apr 20 06:54:00 PDT 2008

Hi there,

I have currently installed these package versions:
x11-drm module from gentoo-sources-2.6.24-r4

I'm using the 2D Intel driver in XAA mode, because EXA isn't really 
stable for me, but that's not my question here.

1) According to the manpage of the intel driver the Legacy3D option 
still exists. However I was under the impression that the "older" i915 
driver was removed and replaced with the i915tex driver completly (while 
renaming i915tex to i915).
Is this correct? I'm a bit confused because the option is still in the 
manual, but according to the X log the driver seems to ignore it.

2) What is this i915tex_branch in GIT about? If I understand this 
correctly it's a updated version of the i915tex driver (which was 
renamed to i915 anyway) which can build with the latest DRI GIT.
Which means that building mesa-7.0.2 with a libdrm GIT snapshot is 
How does the i915tex driver in te i915tex_branch differ from the i915 
driver in the regular mesa GIT (master)? Is it only the patches so it 
builds with GIT snapshots of the DRI components?

3) I heard that the gallium-0.1 branch was supposed to somehow work for 
i915 chipsets. I didn't expect any miracles and tried it out. What can I 
say? It doesn't even build (correctly) for me. I wasn't expecting this, 
but I think it's primarily my fault.
AFAIK there are currently two build systems in the tree, SCons and 
regular Makefile building. I tried out building via Makefile but this 
only builds the GL components and no libs. The funny thing 
is that building via SConstruct does build a library (but 
no GL components).

However I couldn't make gallium work by combining the two builds. Either 
libdrm is too old and when updating libdrm to GIT it's too new (marcheu 
told me about DRI2 problems with gallium on IRC, so I suspect this to be 
the problem).
So I wanted to ask what package versions I need to get this running and 
what target I'm supposed to build when using the Makefile.

I tried
make linux-dri-x86
but that doesn't seem to build the requiered libs. I don't 
want to build the nouveau components, so I passed DRI_DIRS=intel_winsys 
(is this a valid option at all???). I could however create a lib by 
doing a make in src/gallium/winsys/dri/intel. Spits out an error though:
libGL error: dlopen /root/mesa/lib/ failed 
(/root/mesa/lib/ undefined symbol: drmFenceDestroy)

I suppose that libdri is too new. I get a version error with libdrm-2.3.0
Any advice which GIT snapshot of libdrm can be used with gallium?

Is it expected that the code from the i915tex_branch will be integrated 
into the master branch?

Greetings from Germany,
Tobias Jakobi

More information about the xorg mailing list