mesa compilation error

Beso givemesugarr at
Sat Apr 12 01:39:38 PDT 2008

2008/4/11, Daniel Stone <daniel at>:
> On Fri, Apr 11, 2008 at 07:33:51PM +0000, Beso wrote:
> > dri2.c:38:38: error: X11/extensions/dri2proto.h: No such file or
> directory
> Install xorg/proto/dri2proto.
> Cheers,
> Daniel
> Version: GnuPG v1.4.6 (GNU/Linux)
> N72uam/5XtIlD7u7mssg4QA=
> =9vX3
thanks for the help, i've been able to compile the new mesa, but now i get
the following problem:

- when xorg starts with exa and textured video it hangs the pc at the kdm
login screen (the log is clean and it doesn't seem to identify problems).
the strange thing is that magic keys don't work and i'm forced to do a hard
- with xaa the server starts but kde doesn't display window names.

now the problem is surely due to either mesa (+ dri2proto) or
xf86-video-ati. they were the only packages that i've updated yesterday
evening and one of them has broken down the exa server. i know that radeon
is far from perfect with my rs480 but before these 2 updates it has worked
in a discrete way for what i've needed to do.

- now i'm trying to compile libX11 from git + the various git protos updates
and then compile also xorg-server and see if this helps (i would have tried
it today even if i wouldn't get this strange problem). if it doesn't help
i'll try out to remove dri from xorg.conf and see what happens with that.

but if some of you has any idea or suggestion about something else to look
for or to try out (maybe i'll need to try out latest xf86-video-ati released
version to see if with that the server would restart working) i'd be really

dott. ing. beso
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the xorg mailing list