Xorg 7.2 fails to start

Christophe Cap christophe.cap at gdnmail.net
Thu May 31 01:24:12 PDT 2007


I recently upgraded xorg to 7.2 on my FreeBSD machine.
Unfortunately I cannot get X to start.

Reported error :

Fatal server error :  Xf86OpenConsole KDSETMODE KD_GRAPHICS failed.
The x log files don't report any other warning or error.

I triple-checked the UPDATING procedure and couldn't find any step I missed.

Here are some things I already tried :
- use both a new xorg.conf and the original one 
- tried with standard vga driver, nv driver and nvidia driver
- replaced kdm with xdm and back (and increase warning level)
- rebuild & reinstall ports/x11/xorg (the meta port) 

All attemts above result in the same error.

My guess is that it's not a configuration problem.
I suspect either a permission problem or some missing symlink somewhere...

Any ideas where to look ?

Kind regards,


Truly great madness cannot be achieved without significant intelligence.

<a href="http://www.gamedev.net">GameDev.net Email Service</a> - "Plenty of 1's and 0's"

More information about the xorg mailing list