Xvfb strange problem

Glynn Clements glynn at gclements.plus.com
Mon May 21 10:47:41 PDT 2007

GUERRAZ Francois wrote:

> For one of our client's server, we use Xfvb. It is launched in a startup
> script in 800x600x32 resolution.
> Recently they halted (violently I guess) the system. After the reboot,
> we haven't been able to restart Xvfb, it kept failing w/ this message :
> "Fatal server error:
> Couldn't add screen 0"
> So we tried to launch Xvfb in 800x600x16 and now it works like this !
> Of course, our client asks us why did we had to make this change. Could
> you help me to answer them please? :)
> We used to launch Xvfb with this command line :
> # nohup /usr/X11R6/bin/Xvfb :25 -screen scrn 800x600x32 &
> I think there is a bug in it? What the hell is "scrn"??? And why DID it
> worked?

The argument to -screen should be an integer. I suspect that it's
being parsed with a function which stops at the first non-digit (e.g. 
atoi()), so "scrn" gets parsed as 0.

> Now it works with 
> # nohup /usr/X11R6/bin/Xvfb :25 -screen scrn 800x600x16 &

Try 800x600x24.

800x600x32 doesn't work for me, but 800x600x24 does. If you just need
24-bpp colour, then that should be fine. OTOH, if you're relying upon
a specific pixel format, it looks like you're out of luck.

Glynn Clements <glynn at gclements.plus.com>

More information about the xorg mailing list