Unsynced TMDS with xf86-video-intel on 945GM

Jacobo Polavieja jacobopolavieja at gmail.com
Wed May 16 00:04:30 PDT 2007

René Rebe escribió:
> Hi all,
> it appears there is one problem left with xf86-video-intel 2.0.0 on the 945GM
> (as inside the Apple MacBook r2), I use this sniplett to change to a DVI
> connected Apple Cinema Display on X start (.xinitrc):
> if xrandr | grep -q 'TMDS-1 connected'; then
>         xrandr  --output TMDS-1  --preferred
>         xrandr --output LVDS --off
> fi
> However often (like about 80% of the X starts) I get flickering and rolling thru
> pixel trash on the external display. It "looks" like there is some sync (or so)
> missing or imprecise, as it's the actual desktop pixel content flushing and
> shuffling by.
> Interesting is that when I rotate the desktop cube (of Beryl) the image get's
> in sync, and when the Beryl "rotate cube" mode is left the display content
> is unsynced again (rolling and flickering by).
> This can be fixed by re-enabling the LVDS and disabling it again:
> xrandr --output LVDS --auto
> xrandr --output LVDS --off
> Though sometimes even this only worked on the third attempt.
> Once this sequence made the DVI "be synced"(?), it works for
> infinite hours, like whole weeks, until one restarts X or resumes
> from suspend-to-ram.
> Any idea?
I have the same exact problem, though I didn't know about the LVDS
re-enabling once and another... I've tried it and, after like 6
attempts, I now have the external monitor synced correctly and the LVDS
off (thank God!!!).
My external monitor is the Dell 2007WFP, pretty similar to Apple's. I
also have 2nd revision of the Macbook.
You can find my messages about this issue in this list, though no one
seemed to know pretty much.

If you find something about this, please let me know. We'll see if
someone comes up to a conclusion. I've tried to see any xrandr log, but
haven't found anything with which you can track xrandr actions & errors.
Xorg.0.log just keeps track of the initial startup.

Thank you at least for finding a temporary solution... I was sick. Hope
intel people finds out why this behaviour.


P.D: Did you manage to get 3d accel with macbook on external display via

More information about the xorg mailing list