Intel 2.0.0 driver not seeing laptop screen resolutions properly

Eric Anholt eric at
Tue May 8 16:52:10 PDT 2007

On Tue, 2007-05-08 at 15:30 -0700, Greg KH wrote:
> On Tue, May 08, 2007 at 09:52:19AM -0700, Eric Anholt wrote:
> > On Mon, 2007-05-07 at 18:17 -0700, Greg KH wrote:
> > > So, I upgraded to 2.0.0 a few weeks ago, and it worked just fine,
> > > without rebooting my laptop (quit X, restarted, and it was great).  The
> > > same resolution worked (1280x768) both with, and without any xorg.conf
> > > file present.
> > > 
> > > Then I rebooted to use a newer kernel, and I no longer can use 1280x768
> > > anymore, the screen only runs at 1024x768, with a black band on the
> > > right side where the unused pixels are (things aren't stretched to the
> > > whole screen, like they had been in the past when switching to this
> > > resolution.)
> > > 
> > > Attached below is the log file, I don't seem to see any mention of the
> > > 1280x768 resolution in it at all.  I've also attached my xorg.conf file,
> > > just in case I'm doing something really stupid there too.
> > > 
> > > I can try the git version of the intel driver, but it didn't look like
> > > anything had changed in there since the 2.0.0 release that would help
> > > this out.
> > > 
> > > My hardware for this laptop is:
> > > 00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
> > > 
> > > Anyone have any ideas?
> > 
> > Can you put Option "ModeDebug" "YES" in your Driver section and send a
> > new log?
> Sure, attached is the diff between the two logs without and with debug
> enabled, and the whole new log file itself.
> It looks like it sees the bios setting for the proper panel size, but
> that might just be due to me still running the 915resolution program at
> boot time, which used to be required under the old driver to get this
> screen size working.
> I have disabled 915resolution one time, and no difference in result, but
> the log files might be different then, do you want me to try that to see
> that log difference too?

So, in your BIOS-initialized console, you've got a black band on the
right side with a full screen of text, correct?  It looks like your BIOS
was too clever to use the panel fitter, and instead decided to achieve
its goals by taking the 1280x768 panel mode and chopping it down to just
1024x768 active.  Kind of.

Here's a proposed hack to detect your situation and plug in better
values for the detected panel timings.  If it works, I'll add it.  Note
that in your case the BIOS gets the right answer (it looks like).
However, since the BIOS sometimes likes to disappear on us, it's
probably better to have this hack in place.

Eric Anholt                             anholt at
eric at                         eric.anholt at

-------------- next part --------------
A non-text attachment was scrubbed...
Name: gregkh-panel-timings.diff
Type: text/x-patch
Size: 1383 bytes
Desc: not available
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 187 bytes
Desc: This is a digitally signed message part
URL: <>

More information about the xorg mailing list