Intel 2.0.0 driver not seeing laptop screen resolutions properly

Eric Anholt eric at
Tue May 8 09:52:19 PDT 2007

On Mon, 2007-05-07 at 18:17 -0700, Greg KH wrote:
> So, I upgraded to 2.0.0 a few weeks ago, and it worked just fine,
> without rebooting my laptop (quit X, restarted, and it was great).  The
> same resolution worked (1280x768) both with, and without any xorg.conf
> file present.
> Then I rebooted to use a newer kernel, and I no longer can use 1280x768
> anymore, the screen only runs at 1024x768, with a black band on the
> right side where the unused pixels are (things aren't stretched to the
> whole screen, like they had been in the past when switching to this
> resolution.)
> Attached below is the log file, I don't seem to see any mention of the
> 1280x768 resolution in it at all.  I've also attached my xorg.conf file,
> just in case I'm doing something really stupid there too.
> I can try the git version of the intel driver, but it didn't look like
> anything had changed in there since the 2.0.0 release that would help
> this out.
> My hardware for this laptop is:
> 00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
> Anyone have any ideas?

Can you put Option "ModeDebug" "YES" in your Driver section and send a
new log?

Eric Anholt                             anholt at
eric at                         eric.anholt at

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 187 bytes
Desc: This is a digitally signed message part
URL: <>

More information about the xorg mailing list