GARTSize option not documented on radeon and other problems

Zoltan Boszormenyi zboszor at
Thu May 3 08:13:23 PDT 2007


sorry for the crossposting, I don't know who to address.

I am experimenting the new CFS scheduler on Linux
and tried to start multiple glxgears to see whether
they are really running smooth and have evenly
distributed framerate.

At first I could only start two instances of glxgears
but the third didn't start saying that it cannot allocate
GART memory and try to increase increase GARTSize.

First problem: man radeon doesn't have anything about
this option, although contains this keyword.
I tried guessing whether the parameter is in MBs and
have set it to 128 but it disabled DRI because of some
out of memory condition. Setting it to 64 gave me working
DRI and I am able to start up some more instances of

Second problem: if I start 16 of them, the last 3
behaves very strange, i.e. instead of the spinning gears
I get chaotic flickering triangles. As soon as the number
of glxgears goes down to 13 every window behaves

Third problem: starting up 32 glxgears locked up the
machine almost instantly but having only 16 of them
also locks up the machine after some time passed.

The machine is x86-64, Athlon64 X2 4200,
PCIe Radeon X700 with 128MB onboard memory,
up-to-date Fedora Core 6.

Best regards,
Zoltán Böszörményi

More information about the xorg mailing list