xf86-video-intel-1.99.92: server terminates after OpenGL usage

Pavel Troller patrol at sinus.cz
Sun Mar 18 08:17:59 PDT 2007

> On Sun, 2007-03-18 at 08:07 +0100, Pavel Troller wrote:
> > Hi!
> >   I have another strangeness with the new intel driver:
> >   There are apps, which use OpenGL, causing the server to terminate. Sometimes
> > it terminates when an OpenGL window is appearing, sometimes when it's closing.
> > I don't say "crash" because I didn't find any crash dump/report anywhere. It
> > just cleanly blanks the screen and then a new login window appears. I didn't
> > find anything suspicious in the server log, however I'm attaching it for the
> > expert's eye (it's Xorg.0.log.old copied just after the crash).
> >   Simple apps like glxgears never do this; you need a more complex application:
> >   - OpenGL amarok visualization plugin
> >   - OpenGL screensaver (it's enough to test it in the KDE control center)
> >   - OpenGL game.
> >   Of course all this happily worked with the old driver.
> >   Any hints, how to debug this problem ?
> There could be something in the X server's stderr output. If you're
> using a display manager, this may be captured in the display manager's
> log file.
  Bingo! It's there! I'm really stupid that I forgot to look there.
  It's a single line but I think it's this:
X: main/framebuffer.c:219: _mesa_free_framebuffer_data: Assertion `fb->RefCount == 0' failed.
This is the case when it crashed after closing the window.

  It also shows that I forgot that I recompiled also the server to (1.3 RC2). So
this bug is probably not driver related, but it's the server problem. I just tried the old
driver and it crashed as well.

                    With regards, Pavel Troller

More information about the xorg mailing list