Bugs in xf86-video-intel 1.9.91 (2.0 RC1)

Pavel Troller patrol at sinus.cz
Wed Mar 7 11:32:38 PST 2007

> > Keith Packard wrote:
> > > Known regressions: i830 and i855 LVDS do not work.
> > 
> > And much more doesn't work :)
> > I've tested some snapshots of modesetting branch without success on
> > Intel DG965WH motherboard with connected LCD monitor Samsung 173s and
> > with ADD2 card Prolink PV-CH7315(N16TS)-F (nothing connected to card).
> > Now I've tried this release and still no success :(
> > When starting with ADD2 card inserted into MB (still nothing conneted to
> > it) I've only get blank screen and monitor switched off.
> > When starting X without ADD2 card I'm only able to get 1024x768 instead
> > of 1280x1024. Even when I edit xorg.conf and set monitor refresh and
> > modelines, all are ignored. Below is link to log from X starting.
> > http://aflinta.dyndns.org/~aflinta/Xorg.0.log.bz2
> The same here.
>   It's 945G here, and EDID doesn't work. Monitor section of xorg.conf is
> totally ignored. Where are the default monitor data ? I'm going to patch
> them to allow my monitor to work at 1600x1200 as obviously.
>   BTW there are many threads in this list complaining just about this
> problem, and there were never any attempts (AFAIK) to find a real cause
> and solution. I think EDID doesn't work here even with the old driver,
> this is the reason for which I have the monitor data carefully filled in
> xorg.conf. Why they are ignored by the new driver ?
>                                            With regards, Pavel Troller
  Using the information which Keith has provided, I was able to configure
the driver to use my favourite 1600x1200 mode. It was necessery to use the
"monitor-VGA" driver option together with "PreferredMode" monitor option
as well as proper setting of HorizSync, VertRefresh and MaxClock.
  I was trying the driver together with 1.3 RC1 server, which seems to be
very stable with the old intel driver.
  With the 1.9.91 driver, the following bugs have been observed:
  1) After the first X reinit (logging out from KDE), the mouse pointer
was destroyed and replaced by a square full of randomly changing
pattern, of about 64x64 size. The pointer was not repaired even by new
login to KDE, the server had to be killed to restore it.
  3) During the second X reinit X server refused to start. It was necessary
to kill it again.
  3) When switching virtual desktops in KDE, a binary junk (colourful
pixels and patterns) appeared in 2 - 3 topmost screen lines.
  4) Some internal KDE apps (ksplash, kicker, amarok) experienced random
crashes, never observed with the old driver. Together with point 3, I
suspect the driver to cause memory corruption, causing subsequent app
  RandR was fully funoctional including rotation of the screen.
  Because of the bugs mentioned above, this driver still cannot be
considered stable. I had to revert to the old driver for the routine work.
        With regards, Pavel Troller

More information about the xorg mailing list