Bugs in xf86-video-intel 1.9.91 (2.0 RC1)

Ken Mandelberg km at mathcs.emory.edu
Tue Mar 6 06:28:56 PST 2007

The latest code causes my X server to abort during initialization. The 
last few lines of the log are

(II) intel(0): Kernel reported 232960 total, 1 used
(II) intel(0): I830CheckAvailableMemory: 931836 kB available
(**) intel(0): VideoRam: 65536 KB
(**) intel(0): Requested 512 cache lines
(EE) intel(0): [dri] I830CheckDRIAvailable failed: dri not loaded
(II) intel(0): Allocating 512 scanlines for pixmap cache
(II) intel(0): Memory allocation layout:
(II) intel(0): 0x00000000-0x0001ffff: ring buffer (128 kB)
(II) intel(0): 0x00020000-0x00027fff: logical 3D context (32 kB)
(II) intel(0): 0x00030000-0x0062ffff: front buffer (6144 kB)
(II) intel(0): 0x00630000-0x0063ffff: xaa scratch (64 kB)
(II) intel(0): 0x00fbf000:            end of stolen memory
(II) intel(0): 0x00fbf000-0x00fbffff: HW cursor (4 kB, 0x0df18000 physical)
(II) intel(0): 0x00fc0000-0x00fc3fff: HW ARGB cursor (16 kB, 0x02fc0000 
(II) intel(0): 0x00fc4000-0x00fc4fff: HW cursor (4 kB, 0x2d8b1000 physical)
(II) intel(0): 0x00fc5000-0x00fc8fff: HW ARGB cursor (16 kB, 0x0d9ec000 
(II) intel(0): 0x10000000:            end of aperture
(II) intel(0): front buffer is not tiled
(==) intel(0): Write-combining range (0x80000000,0x10000000)
(II) intel(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 

0: /usr/bin/X(xf86SigHandler+0x81) [0x80cbf81]
1: [0xb7f7b420]
2: /usr/bin/X(AddScreen+0x1ee) [0x806de8e]
3: /usr/bin/X(InitOutput+0x21e) [0x809f54e]
4: /usr/bin/X(main+0x27b) [0x806e63b]
5: /lib/libc.so.6(__libc_start_main+0xdc) [0xb7d01f9c]
6: /usr/bin/X(FontFileCompleteXLFD+0x1e1) [0x806db71]

Fatal server error:
Caught signal 11.  Server aborting

Full log at http://www.mathcs.emory.edu/~km/Xorg.0.log.abort

The last git code that worked for me was about 10 days old and had the 
problem that it rejected all but the generic resolutions probably based 
on the built in horizontal 31-55, vertical 58-62 defaults. On that code 
I tried the suggestion of adding a separate VGA monitor section with

Section "Device"
   BoardName    "945 GM"
   BusID        "0:2:0"
   Driver       "i810"
   Identifier   "Device[0]"
   Option       "NoDDC"
   Option       "LinearAlloc" "12288"
   Option        "CacheLines"    "512
   VideoRam      65536
   VendorName   "Intel"
   Option "monitor-VGA" "MyVgaMonitorSection"
Section "MyVgaMonitorSection"
   DisplaySize  340 270
   HorizSync    30-80
   Identifier   "MyVgaMonitorSection[0]"
   Option       "DPMS"
   VendorName   "DMI"
   VertRefresh  43-80
   UseModes     "Modes[0]"

and get

Parse error on line 95 of section MyVgaMonitorSection in file 
/etc/X11/xorg.conf        "MyVgaMonitorSection" is not a valid section name.

I presume I have the syntax wrong.

More information about the xorg mailing list