Another compile problem (X11R7.1): "error: 'TS_Raw' undeclared"

Tobias Gerschner tobias.gerschner at
Wed Jan 10 10:47:20 PST 2007

> ------------------------------
> Message: 8
> Date: Wed, 10 Jan 2007 13:45:45 +0100
> From: "Harmuth, Florian" <fhar at>
> Subject: Another compile problem (X11R7.1): "error: 'TS_Raw'
>         undeclared"
> To: <xorg at>
> Message-ID:
>         <2D6F4E675EF5F04D8F97184E32378A1B2897AF at msc-ex02.msc-ge.mscnet>
> Content-Type: text/plain; charset="iso-8859-1"
> Hello all,
> after building the xserver successfully (with: --disable-dmx --disable-xprint --disable-dri), i run now into another problem.
> xf86Calcomp.c:47:1: warning: "NEED_XF86_TYPES" redefined
> In file included from ../config.h:4,
>                  from xf86Calcomp.c:37:
> /usr/include/xorg/xorg-server.h:75:1: warning: this is the location of the previous definition
> xf86Calcomp.c: In function 'CalcompPreInit':
> xf86Calcomp.c:682: error: 'TS_Raw' undeclared (first use in this function)
> xf86Calcomp.c:682: error: (Each undeclared identifier is reported only once
> xf86Calcomp.c:682: error: for each function it appears in.)
> xf86Calcomp.c:684: error: 'TS_Scaled' undeclared (first use in this function)
> make[2]: *** [xf86Calcomp.lo] Fehler 1
> make[1]: *** [all-recursive] Fehler 1
> make: *** [all] Fehler 2
> root at fhar-desktop:~/tmp/X11R7.1_new#


that error happens because your inputproto is too new. You have to
downgrade it. I run into the same problem some weeks ago. You can find
my mail in the archives. According to Daniel Stone this is because the
newest inputproto release is for xorg 7.3 and not for 7.2 . A couple
of drivers won't build.

The thread can be find here :


Tobias Gerschner
Member of Board of Yoper Linux Ltd. NZ

Knowing is not enough; we must apply. Willing is not enough; we must do.

More information about the xorg mailing list