Xorg 1.1.1 + Mesa 6.5.2 = White screens with i810 driver and beryl/compiz

Emilio Scalise emisca.ml at gmail.com
Sun Jan 7 14:32:13 PST 2007

I had also the same white cube problem when I tried to update mesa on
my ubuntu edgy distro (intel 945gma). I use now 1.7.2 driver. I
noticed that using mesa version 6.5.1 (20060817 prerelease version,
the one shipped with edgy) I have no problems. Using final version
6.5.1 from debian (recompiled on my machine) I have the white cube
problem. Perhaps I have not rebuilt the server.........
I think that this problem is due to version mismatchs between
components... definitely what is the dependency order to obtain a
working build?
Later I have tried using Ross Burton mesa 6.5.2 packages....white cube
I would like to use: Xorg 1.1.1 + mesa 6.5.2 + i810 1.7.3 + libdrm
2.3. What is the compilation order to get it working? Does the
mentioned patch affects also Xserver 1.1.1?

2007/1/7, Colin Guthrie <gmane at colin.guthr.ie>:
> Colin Guthrie wrote:
> > I'll double check a few more things...
> Yeah, double checked and I'd forgotten to rebuild the driver against new
> mesa (not sure if it's needed) but it didn't make any odds anyway :(
> So I've got Mesa 6.5.2, glproto 1.4.7, and xorg server 7.2 RC3, i810
> driver 1.7.3.
> Everything built in the correct order. Do you think there is anything
> else that should be rebuilt for either the Mesa or for the xserver
> itself being updated?
> Judging by how many other people also seem to have the issues I still
> think there must be some sort of upstream problem.
> :(
> It appears to not affect nvidia prop. driver users, so perhaps it's just
> your users are mostly nvidia ones and the bug actually still exists in
> your builds too? (unlikely I guess)
> Col.
> _______________________________________________
> xorg mailing list
> xorg at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/xorg

More information about the xorg mailing list