opengl causes lockups with xf86-video-intel 2.0.0 and xorg-server 1.3

Björn Martensen bjoern.martensen at
Thu Apr 26 12:57:50 PDT 2007

whenever i run opengl applications, be it beryl, ezquake or sth like
that, after some time the whole x-server freezes. with xorg-server 1.2
and previous i810 driver this meant a total lockup of the system, with
xorg-server 1.3 and intel 2.0.0 in most cases the x-server dies and is
restarted automatically.

i run a gma 950 on a thinkpad t60 with arch linux and compiled
xorg-server and the intel driver myself, the rest is default arch stuff.

i also get strange lockups when i shutdown the system or try to suspend
to ram: at the top of the screen, some red and white pixels are visible,
the rest of the screen is black and the system is completely frozen.
this actually happens with and without the glx module.

i attached the needed files (xorg.conf, Xorg.0.log and Xorg.0.log.old)
to bugzilla, but i'd like to know if i'm the only one with those lockups
or if there are more out there... 
bugzilla bug:

i hope someone can help me.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <>

More information about the xorg mailing list