Xorg building

Russell Shaw rjshaw at netspace.net.au
Sun Jul 9 06:28:36 PDT 2006

Carlos Eduardo Rodrigues Diógenes wrote:
> On Sun, 2006-07-09 at 19:36 +1000, Russell Shaw wrote:
>>Lars Noschinski wrote:
>>>* Russell Shaw <rjshaw at netspace.net.au> [2006-07-09 09:57]:
>>>>When building Xorg-server 7.1, "make" fails if GL/gl.h is missing,
>>>>because configure doesn't look for it. On debian, it is provided
>>>>by mesa-common-dev.
>>>This is mentioned on http://wiki.x.org/wiki/ModularDevelopersGuide. X
>>>depends on Mesa sources to build with GLX.
>>Ok. I forgot about that and missed it in configure --help.
>>I tried again with:
>>   ./configure CFLAGS="-g -O0" --with-mesa-source=../Mesa-6.4.1
>>but it gives errors:
>>checking for linuxdoc... no
>>checking for ps2pdf... no
>>checking Whether to build documentation... no
>>checking Whether to build pdf documentation... no
>>checking for XLIB... yes
>>checking for GL... yes
>>Creating destination directories for mesa module ... DONE
>>Creating destination directories for glx module ... DONE
>>Checking that the source files exist for mesa module ...
>>    error:   /home/russell/SRC/Mesa-6.4.1/src/mesa/main/depthstencil.c not found
>>configure: error: Failed to link Mesa source tree.  Please specify a proper path to Mesa sources, or 
>>disable GLX.
>>I couldn't manually find depthstencil.c in the Mesa-6.4.1 tree, but this is the mesa
>>recommended by the Xorg wiki.
>>depthstencil.c is in the Mesa-6.5 tree, but this build gave other errors.
> Clean your tree and try again with Mesa-6.5. I thinked that it gave
> errors too, but was some other mistake that I do. After removing the
> xorg-server-X117.1 dir, unpacking it again, running configure and
> compiling with Mesa-6.5, everything works fine.

I unpacked a new 7.1 tree twice and tried building with mesa-6.4.1 and mesa-6.5.
Both stopped because of errors. Both built ok when i used the option: --disable-glx

More information about the xorg mailing list