Alan James Caruana ajcaruana at gmail.com
Fri Aug 18 02:33:54 PDT 2006

Thanks. This time, ftfuncs.c compiled, but the compilations stopped at
another file called "util.c" in the archive
"fonttosfnt-X11R7.0-1.0.1".  The error message is the same, and the
line reads like :


I tried looking in the same folder in which there is the
libXfont-1.2.0.tar.bz2 which you pointed me to for the previous
problem.  I also looked in the folder for X11R7.0 and X11R7.1, but did
not find anything.  Where can I find version 2 of this archive? If it
does not exist, how can I solve this problem?

Alan Caruana

On 8/18/06, Russell Shaw <rjshaw at netspace.net.au> wrote:
> Alan James Caruana wrote:
> > I was trying to compile X11R7.0 and it stopped at a file called ftfuncs.c.
> > The error it gave was that #include expects to be followed by <filename>
> > or "filename".
> > I found the line where it gave the error, which reads like this:
> >
> > #include FT_TRUETYPE_TAGS_H
> > #include FT_INTERNAL_SFNT_H
> >
> > I tried searching for the definitions of all three of them throughout
> > the whole system, but they dont seem to show up anywhere. What am I doing wrong?
> Xorg did bad things and used freetype internal headers, but you probably don't
> have the old freetype on your system. Install libXfont which doesn't use the
> internal headers:
> http://xorg.freedesktop.org/releases/individual/lib/libXfont-1.2.0.tar.bz2
> _______________________________________________
> xorg mailing list
> xorg at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/xorg

More information about the xorg mailing list