X.org 7.{0,1}: Can't start mplayer on X :1 from X :0

Rutger Nijlunsing rutger at nospam.com
Sun Aug 13 05:00:38 PDT 2006

On Sat, Aug 12, 2006 at 10:46:49PM +0200, Sebastian Kemper wrote:
> Hi all,
> I'm trying to start mplayer on a new X server (:1) from within a running
> X (:0). It usually works the first time, but further attempts fail.
> - It worked fine with X.org 6.8.2, even repeated attemts were successful.
> - Starting mplayer on X :1 from console works every time.
> I use the following script:
> #!/bin/bash
> X -layout TV :1 -ac 1> /tmp/X.1.log 2> /tmp/X.1.err & DISPLAY=:1 mplayer
> -fs -really-quiet -monitoraspect "662:373" -fs "$@" 1> /tmp/mplayer.log
> 2> /tmp/mplayer.err ; kill `ps aux | awk '/X\ -layout/ {print $2}'`
> (sorry for the line breaks, it really is a one liner)

I encountered something alike. I always start two X servers (one per
user; it gives me easy quick user switching).

The first X display is a standard Debian Unstable KDE session
(targetted at the other user :). The second one is a script:

  export DISPLAY=:1; X $DISPLAY & sleep 10; source ~/.xsession

...and in ~/.xsession something along the lines of:

xrdb -merge ~/.Xdefaults
xmodmap ~/.Xmodmap
xhost local:
source ~/.xset.sh
xsetroot -solid '#403030'
exec icewm-session

This worked before Xorg modularisation and stopped working
afterwards. Don't know which versions exactly.

'stopped working' means:
  - X server aborts early (during .xsession)
  - X server reset itself multiple times (screen, no screen, screen, ..)
  - At the console from where I start an X server, it seems something
    is pressing the ENTER keys indefinately until I press ENTER myself.

I don't know where to file this: at Debian bug tracker or at X.org? I
cannot arbitrary change versions, so I left it at this.


The workaround for me was to start the window manager _before_ other
programs, so:

/usr/bin/icewm-session &
sleep 5
xrdb -merge ~/.Xdefaults

Ugly, but required.

So for the mplayer case I would suggest adding a window manager.

Rutger Nijlunsing ---------------------------------- eludias ed dse.nl
never attribute to a conspiracy which can be explained by incompetence

More information about the xorg mailing list