[Xorg] VFB: problem with unsupported bit depth.

jplee at astrazeneca.com jplee at astrazeneca.com
Tue Jul 20 12:28:58 PDT 2004

I hope someone can help me. My sysadmin built and installed xvfb on a 
Solaris 5.8 machine. I am tying to access it from a java servlet running
Tomcat 4.1.27, JVM 1.4.1_01-b01. Xvfb was initially started by the Tomcat
like so:
/usr/X11R6/bin/Xvfb :1 -screen 0 1280x1024x8 -fbdir /tmp &

My servlet creates a java Frame object and then attempts to create an Image
in it.
Headless mode wouldn't work, due to a conflict with a needed JAR file. I
receive the following
error when I try to associate the screen resource with it:
sun.java2d.InvalidPipeException: Unsupported bit depth: 4
at sun.awt.X11SurfaceData.getSurfaceType(X11SurfaceData.java:424)
at sun.awt.X11GraphicsConfig.getSurfaceType(X11GraphicsConfig.java:116)
at sun.awt.X11SurfaceData.createData(X11SurfaceData.java:284)
at sun.awt.motif.MComponentPeer.initialize(MComponentPeer.java:193)
at sun.awt.motif.MComponentPeer.init(MComponentPeer.java:225)
at sun.awt.motif.MWindowPeer.init(MWindowPeer.java:93)
at sun.awt.motif.MFramePeer.(MFramePeer.java:58)
at sun.awt.motif.MToolkit.createFrame(MToolkit.java:197)
at java.awt.Frame.addNotify(Frame.java:469)
. . .

I tried setting "-pixdepths 4" on the cmd line, but receive the same error.
I am not 
prescribing a pixel depth of 4 bpp in my code, so it must have something to
with xvfb, or a display driver. Does xvfb use a display driver, or is it the
display driver?
Is there some other setting needed in the build process? 
Can someone explain what happens when the X server starts up, what resources
it grabs, etc?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.x.org/archives/xorg/attachments/20040720/c159828f/attachment.html>

More information about the xorg mailing list