[Xorg-driver-geode] Update -- The RandR-"unable to set rotation" issue in AMD Geode LX platform

Mitch Davis mjd-xorg-driver-geode at afork.com
Fri Jun 18 00:25:58 PDT 2010

On Thu, Jun 17, 2010 at 10:50 PM, Mitch Davis
<mjd-xorg-driver-geode at afork.com> wrote:
> On Thu, Jun 17, 2010 at 8:00 PM, Cui, Hunk <Hunk.Cui at amd.com> wrote:
>> 1. As mentioned about the RandR-"unable to set rotation" issue, in our
>> I modify the code and upload a diff patch for tests, now the update methods
>> have been test in Ubuntu desktop. (rotate right)
>> I have repeatedly tested this method in Xserver 1.7, but in Xserver 1.8,
>> still have some problem, so I will go to research the reason.
> Hi Hunk,
> Thank you for this.  I am using 1.7.5, so I will definitely try it out tomorrow.

I have just tried it out with 1.7.5.  I don't get the black screen,
but I don't get rotation either.  I think maybe I'm doing it wrong.

Here is my xorg.conf file:


Here is my X log:


It has these errors:

  (EE) GEODE(0): Couldn't allocate the shadow memory for rotation
  (EE) GEODE(0):  You need 0x300000 bytes, but only 0x0 bytes are available

Just to confirm, here is the patch I'm using:


I have tried setting rotation using xrandr -o.  xrandr -o 2 gives me this error:

$ xrandr -o 2
Failed to change the screen configuration!

xrandr -o 2 is ok.

$ xrandr -o 0

Can anyone make any suggestions please?



More information about the Xorg-driver-geode mailing list