Bug#992617: xserver-xorg-video-radeon: Screen rotate doesn't work

Michel Dänzer michel at daenzer.net
Fri Aug 27 10:20:55 UTC 2021

On 2021-08-21 4:58 p.m., Kari Pahula wrote:
> On Sat, Aug 21, 2021 at 12:17:02PM +0200, Michel Dänzer wrote:
>>> DRM Information from dmesg:
>>> ---------------------------
>> Since there are no DRM driver related messages in dmesg, looks like
>> something is preventing the radeon kernel driver from loading at
>> all. If you're passing nomodeset on the kernel command line, remove
>> that. Otherwise, full dmesg output would be needed to diagnose.
> I'm not using nomodeset.  I've attached a dump from dmesg after a
> reboot.  That "ring 0 stalled" message doesn't look promising at all.

Yeah, that's a GPU hang.

> Actually, when I first tried running startx it just stopped after
> showing the initial log messages to tty, while occasionally blinking
> my screens black.  I did a kill -9 on the Xorg process and then startx
> worked when I tried it again, but I guess it gave up on any
> acceleration at that point.


> I tried booting the last kernel I had (linux-image-5.10.0-4) and the
> one from Buster but those didn't solve anything.

What else changed on the system since it was last working? E.g. if Mesa packages were upgraded, it's worth trying to downgrade those. Or maybe xserver-xorg-video-radeon.

Earthling Michel Dänzer               |               https://redhat.com
Libre software enthusiast             |             Mesa and X developer

More information about the xorg-driver-ati mailing list