[Bug 111004] X crash in memcpy (RX590)

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Jun 26 16:17:17 UTC 2019


--- Comment #2 from maxamar at mail.ru ---
> This looks like a bug in /lib/x86_64-linux-gnu/libc.so.6, executing an instruction which isn't supported by your CPU.
That's really KVM by-design bug - offending instruction is SSE movups which in
conjunction with GPU address space requires KVM to emulate this SSE instruction
which it can't.
I insist that this is Mesa's issue as standard memcpy would need to know if it
runs inside KVM & if the address is in GPU space. Mesa should have it's own
memcpy at least for accessing GPU memory space.

> How exactly did you "replace memcpy"?
In the source code replace calls to memcpy with calls to memcpy_new.

> If this isn't due to an issue with your memcpy replacement, it's probably a Mesa issue or maybe a kernel one, but most certainly not an xf86-video-amdgpu one.
These messages are generated by AMD amdgpu kernel module.

BTW I solved my issue by changing BIOS to UEFI in KVM, however, baremetal
version still doesn't work which is not good. Now my glibc memcpy choses
another path without SSE instructions, I think.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.x.org/archives/xorg-driver-ati/attachments/20190626/e250c6d2/attachment.html>

More information about the xorg-driver-ati mailing list