[Bug 108650] New: In some games cursor is either invisible or with artifacts

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sun Nov 4 11:18:51 UTC 2018


            Bug ID: 108650
           Summary: In some games cursor is either invisible or with
           Product: xorg
           Version: git
          Hardware: x86-64 (AMD64)
                OS: Linux (All)
            Status: NEW
          Severity: normal
          Priority: medium
         Component: Driver/AMDgpu
          Assignee: xorg-driver-ati at lists.x.org
          Reporter: mceier+freedesktop at gmail.com
        QA Contact: xorg-team at lists.x.org

Cursor in Pathfinder:Kingmaker has artifacts, in Hands of Fate 2 is invisible,
and in Gremlins is barely visible.

I have R9 Fury X with 2 monitors and I'm using mesa-19.0.0 from git (
5c0cff868a48202df1ddb30d1dca848101063cb6 ), xorg-server from git (
c901adc327bce4c0d19caf350cbcb0cd5254f306 ), libdrm from git (
0be850441f24c55cf5a2f1ce3b33457add685b96 ), kernel-4.19.0 (
5f21585384a4a69b8bfdd2cae7e3648ae805f57d ) and xf86-video-amdgpu from git (
1cb338253af9c539fc1f13fc12b255ed6303f8b1 ).

I saw there was patch 2 weeks ago that tried to fix cursor in the Civilization
VI ( ad6dfb0124860cf67730bde85867f81d9258c84d, "Detect and fix up
non-premultiplied cursor data" ) and I tried to revert it but this didn't fix
issue with the games mentioned above.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.x.org/archives/xorg-driver-ati/attachments/20181104/f0bdb224/attachment.html>

More information about the xorg-driver-ati mailing list