[Bug 99215] New: AMDgpu freeze results in color corruption (red artifacts) in X on every subsequent boot

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Dec 28 21:13:32 UTC 2016


            Bug ID: 99215
           Summary: AMDgpu freeze results in color corruption (red
                    artifacts) in X on every subsequent boot
           Product: xorg
           Version: git
          Hardware: x86-64 (AMD64)
                OS: Linux (All)
            Status: NEW
          Severity: normal
          Priority: medium
         Component: Driver/AMDgpu
          Assignee: xorg-driver-ati at lists.x.org
          Reporter: chewi at gentoo.org
        QA Contact: xorg-team at lists.x.org

This is a weird one. I was playing the Talos Principle while hacking xboxdrv to
support the Steam Controller. While switching windows, it got into an odd state
and the whole display froze. I was able to ssh in from another machine and
issue a reboot but after losing contact, it didn't actually reboot. I hit the
power button.

When X came back up, it had weird red artifacts all over the place. It's hard
to describe so here's a screenshot.


I tried rebooting again. Same thing. I'm on Gentoo so I tried
upgrading/downgrading various things but nothing has made any difference. I was
then notified of a Gentoo forum thread where another user had encountered the
same thing following some kind of crash or freeze in QuDos (Quake 2). This is
his screenshot.


The only thing I upgraded since the previous reboot that could possibly be
related was LLVM from 3.9.0 to 3.9.1. I haven't downgraded that because it
takes ages to build and I doubt that is the cause.

I have fired up the Talos Principle again in the hope that it would knock
things back into the shape. The game looks fine but the desktop remains

I tried firing up Weston (which I don't normally use) and it didn't show the
same corruption when I launched Thunar. That may be a red herring. Excuse the
pun. :)

linux: 4.9 (and 4.8.14)
xorg-server: 1.18.4
xf86-video-amdgpu: b5c189473d (and 1.2.0)
libdrm: eebefaf72c (and 2.4.74)
llvm: 3.9.1
mesa: 13.0.2

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.x.org/archives/xorg-driver-ati/attachments/20161228/138e6bf5/attachment.html>

More information about the xorg-driver-ati mailing list