[Bug 99052] New: xrandr --scale-from sometimes only uses a corner of the screen when downscaling

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sun Dec 11 10:07:54 UTC 2016


            Bug ID: 99052
           Summary: xrandr --scale-from sometimes only uses a corner of
                    the screen when downscaling
           Product: xorg
           Version: git
          Hardware: x86-64 (AMD64)
                OS: Linux (All)
            Status: NEW
          Severity: normal
          Priority: medium
         Component: Driver/AMDgpu
          Assignee: xorg-driver-ati at lists.x.org
          Reporter: chewi at gentoo.org
        QA Contact: xorg-team at lists.x.org

Alien Isolation has very bad aliasing and none of the game's built-in
anti-aliasing methods are very effective. This is even a problem on Windows but
at least those users have the option of using a mod that adds TXAA. Sadly it's
very Windows/D3D specific. The best available option to Linux users is to
render at a higher resolution and downscale. The game does not allow this
natively so you need to use xrandr's --scale-from option and I gather this
works for NVIDIA users. No such luck on an RX 480 under amdgpu + Mesa.

xrandr --output HDMI-A-0 --mode 1920x1080 --scale-from 3840x2160

I initially tried the above. The desktop (XFCE) scales correctly but the mouse
is locked to the top-left quarter of the screen. Both Alien and Neverball start
but only render in the bottom-left quarter of the screen. Neither allows you to
select a resolution greater than 1920x1080.

I then found an IRC log where agd5f said that you also need to add a mode for
the new resolution, although this was in a discussion about upscaling.

xrandr --newmode "3840x2160"  712.75  3840 4160 4576 5312  2160 2163 2168 2237
-hsync +vsync
xrandr --addmode HDMI-A-0 "3840x2160"

This gave the same result except that Alien did allow me to select 3840x2160.
Doing so made no difference in fullscreen but in windowed, it actually did
render at the correct size, albeit with added window decorations. Neverball was
the same except that it doesn't allow you to choose the fullscreen resolution.
Note that it has a hardcoded list of modes that only goes up to 2560x1440 so I
had to hack the higher mode in myself.

I've seen XFCE do weird things in the past so I also tried with Oroborus, a
much simpler WM, to rule that out but it didn't make any difference.

So in summary, it seems like it's nearly there but something's not quite right.

Linux: 4.8.14
Mesa: 13.0.2
xorg-server: 1.18.4
amdgpu: d60ea478cf2215ded7e1acf5817a0dae07e54026
libdrm: 08257927231e4f51c38e1d2bdbb8db0c2d4aec40

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.x.org/archives/xorg-driver-ati/attachments/20161211/fdb3c368/attachment.html>

More information about the xorg-driver-ati mailing list