Bug#783705: xserver-xorg-video-radeon: Weird X wakeup problem since Jessie upgrade

Steve McIntyre steve at einval.com
Tue May 5 04:40:54 PDT 2015

On Wed, Apr 29, 2015 at 12:45:29PM +0100, Steve McIntyre wrote:
>In the morning, I turn on the screen and I don't get a display at
>all. I've wiggled the mouse, hit numlock on the keybard (the numlock
>led illuminates fine), etc., but no display. I've seen this kind of
>thing happen in the past on some machines, so I switch to VT1 and back
>to see if that helps. Still no display at all, either on console or
>under X. I log in remotely and I can see that the Xorg.0.log file has
>been updated with mode lines for the monitor, suggesting things have
>just woken up fine. But still no display.

Similar problem this morning. I've found that using xrandr to disable
and re-enable the DisplayPort output I'm using helps - the display
comes back. Until xrandr segfaults, anyway - see separate bug.

Something weird in the card state, I guess?

Steve McIntyre, Cambridge, UK.                                steve at einval.com
"This dress doesn't reverse." -- Alden Spiess

More information about the xorg-driver-ati mailing list