[Bug 88927] [Acer Aspire 4820TG] Kernel: trying to unbind memory from uninitialized GART !; EIP is at radeon_gart_unbind+0xca/0xe0 [radeon]()

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sat Apr 25 07:09:42 PDT 2015


--- Comment #4 from Lorenzo S. <lorenzo.stanco at gmail.com> ---
I have the same problem of OP (tiagdtd-lava) on Xubuntu 15.04 on Acer Aspire
4820TG with Radeon HD 5650. GUI freezes every 6-10 seconds for a whole second.
Every time it freezes, fan speeds up and all of these lines are printed in
kern.log: http://pastebin.com/raw.php?i=Rd63ZvHh

Kernel version is:
Linux TIMELINEX 3.19.0-15-generic #15-Ubuntu SMP Thu Apr 16 23:32:37 UTC 2015
x86_64 x86_64 x86_64 GNU/Linux

Previosly Xubuntu 14.04.2 LTS was installed on the same laptop with no problems
regarding X, Radeon or switchable graphics. Graphics switch was completely
automatic (DynOn/DynOff) in 14.04.2, but now in 15.04 is not.

I didn't tested kernel patches because I'm not practical about kernel
recompiling (as you could guess when you read I'm a Xubuntu user). But I tried
some kernel parameters and these are the results:

1) pci=noacpi OR noacpi

No more freezes, but external USB mouse (and maybe other devices) stopped
working at all :(

2) radeon.runpm=0

As suggested here https://bugzilla.kernel.org/show_bug.cgi?id=79701 and here
https://bugzilla.kernel.org/show_bug.cgi?id=72701 this solve freezes and does
not stop external devices to work. Anyway, as reported here
https://bugzilla.kernel.org/show_bug.cgi?id=72701 by klod, this reduces battery
life and increase internal temperature, because it does not turn off discrete

# cat /sys/kernel/debug/vgaswitcheroo/switch
0:DIS-Audio: :Pwr:0000:01:00.1
2:DIS: :Pwr:0000:01:00.0

If I try to manually turn off discrete grahics using:

# echo "DIGD" > /sys/kernel/debug/vgaswitcheroo/switch
# echo "OFF"  > /sys/kernel/debug/vgaswitcheroo/switch

But as soon as I run these commands, in kern.log these lines are printed:
http://pastebin.com/raw.php?i=WwSgEsEt (and it repeats at regular intervals),
fan speeds up again and does not stop, system became instable, network stops
working and system shut down hangs!

Is there a change I can fix this, or it's better if I downgrade to 14.04.2 LTS?

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.x.org/archives/xorg-driver-ati/attachments/20150425/43267bfc/attachment.html>

More information about the xorg-driver-ati mailing list