[Bug 76367] Corrupted second monitor 2D rendering

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Nov 19 09:56:40 PST 2014


--- Comment #8 from Don <harden1 at gmail.com> ---
I have a very similar issue if not exactly the same issue.

Hardware:  HP ZBook14 
:> lspci |grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated
Graphics Controller (rev 0b)
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Mars
[Radeon HD 8730M]

> head  /var/log/Xorg.0.log
[     8.195]
X.Org X Server 1.14.4
Release Date: 2013-10-31
[     8.195] X Protocol Version 11, Revision 0
[     8.195] Build Operating System:  3.14.3-200.fc20.x86_64
[     8.195] Current Operating System: Linux metis.amer.corp.local
3.17.2-200.fc20.x86_64 #1 SMP Tue Nov 4 18:04:56 UTC 2014 x86_64
[     8.195] Kernel command line:
root=UUID=589909ab-eb3b-41ee-9751-1f6fa8e3a605 ro
vconsole.font=latarcyrheb-sun16 crashkernel=auto rhgb quiet LANG=en_US.UTF-8
[     8.195] Build Date: 27 June 2014  01:35:28AM
[     8.195] Build ID: xorg-x11-server 1.14.4-11.fc20
[     8.195] Current version of pixman: 0.30.0

> grep -iA4 radeon_drv.so /var/log/Xorg.0.log
[     8.207] (II) Loading /usr/lib64/xorg/modules/drivers/radeon_drv.so
[     8.207] (II) Module radeon: vendor="X.Org Foundation"
[     8.207]    compiled for 1.14.3, module version = 7.2.99
[     8.207]    Module class: X.Org Video Driver
[     8.207]    ABI class: X.Org Video Driver, version 14.1

> grep -iA4 intel_drv.so /var/log/Xorg.0.log
[     8.206] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[     8.206] (II) Module intel: vendor="X.Org Foundation"
[     8.206]    compiled for 1.14.4, module version = 2.21.15
[     8.206]    Module class: X.Org Video Driver
[     8.206]    ABI class: X.Org Video Driver, version 14.1

> xrandr --listproviders
Providers: number : 3
Provider 0: id: 0x90 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs:
3 outputs: 5 associated providers: 2 name:Intel
Provider 1: id: 0x53 cap: 0xf, Source Output, Sink Output, Source Offload, Sink
Offload crtcs: 2 outputs: 2 associated providers: 2 name:radeon
Provider 2: id: 0x53 cap: 0xf, Source Output, Sink Output, Source Offload, Sink
Offload crtcs: 2 outputs: 2 associated providers: 2 name:radeon

The laptop (internal) screen works great.  When docked, a monitor attached to
the VGA (HD 15) port works great, but the same monitor attached to either of
the DP ports does not redraw correctly.  That is if I move a window there is a
trail of pieces of the window from the original position to the new position.  
Similarly, if I do an `ls -la' in a window the files are not visible unless I
slightly move the window, hit enter, or otherwise cause the screen to be
redrawn.  I have tried several different cable and monitor combinations all
with the same result.

I am happy to provide any additional info.


You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.x.org/archives/xorg-driver-ati/attachments/20141119/6fdc082e/attachment.html>

More information about the xorg-driver-ati mailing list