Black screen on X with acceleration on 7870 GPU

Alexandre Biron bironalexandre at
Sun Jul 20 07:33:58 PDT 2014


For more than a year, I've been trying to use the free radeon driver
for X. I have a 7870 Tahiti card.
On all linux distributions I've tried (Debian, Ubuntu, Arch, Fedora)
I've been unable to use it. I've been through kernel from 3.10 up to
3.14, Mesa from 9.x to 10.2, including 10.3 from dev branch, Xorg
server 1.15 and the recently released 1.16, always to the result: if
acceleration/glamor is enabled, as soon as X is started (either
through startx or a display manager, linux sort of hangs. It's not
exactly crashed, the gpu seems go to an invalid state, where my
monitor loses its connection to it and goes to power saving. Something
is still "happening" as my fans start spinning faster most of the
time, or so it seems.

I use the "default"/automatic X settings, i.e. no xorg.conf (even
though I tried playing with some settings in case it helped).

I can't switch virtual consoles anymore or do anything but press the
reset button. I don't think my card is faulty since it works perfectly
fine in Windows and with fglrx on linux. KMS works fine while I'm in
linux console before I start X. If I start X without acceleration and
mesa falls back to the llvmpipe it also works fine (but slowly of
course). If I look at the Xorg log there are no errors at all: the
card was detected, the monitor was detected and put in a proper mode,
glamor is initialized, etc. And more stuff is initialized without
error after the video card in the log so it doesn't seem to be stalled
or crashed or anything during the graphics part.

My question is then: any ideas? :) I would be glad to debug it in
detail. I'm a professional programmer so I can go pretty deep and can
understand the low level as needed. However I make video games, not
driver/OS stuff so I'm not sure how exactly to attack/debug this
issue, so any hints would be appreciated.

(And maybe this is a mesa/linux-drm issue and should be sent to
another list, but I have no clue... Sorry if that's the case)


More information about the xorg-driver-ati mailing list