[Bug 70880] New: No HDMI Audio on RS880 [Radeon HD 4290]

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Fri Oct 25 18:39:53 PDT 2013


          Priority: medium
            Bug ID: 70880
          Assignee: xorg-driver-ati at lists.x.org
           Summary: No HDMI Audio on RS880 [Radeon HD 4290]
        QA Contact: xorg-team at lists.x.org
          Severity: normal
    Classification: Unclassified
                OS: All
          Reporter: e.swanson+xorgbugs at alloscomp.com
          Hardware: Other
            Status: NEW
           Version: unspecified
         Component: Driver/Radeon
           Product: xorg

Created attachment 88136
  --> https://bugs.freedesktop.org/attachment.cgi?id=88136&action=edit
dmesg on 3.11.6

HDMI audio was working at some point in the past. Some upgrades or changes I
did while on Ubuntu 13.04 caused it to stop working, so I tried to upgrade to
13.10. I also tried upgrading to a newer 3.11 generic kernel (which didn't

$ uname -a
Linux fserv 3.11.6-031106-generic #201310181453 SMP Fri Oct 18 18:54:15 UTC
2013 x86_64 x86_64 x86_64 GNU/Linux

I have the radeon.audio=1 parameter in my kernel command line, and I've got the
1,3 device in my aplay -l. When I try playing a sound through the speakers,
using mplayer, aplay, or speaker-test, it looks like it's working, but I get no

The TV's sound works fine with other machines, and used to work with this
machine. I've attached my dmesg, the output of avivotools regs hdmi, some
output from aplay, and my asound.conf.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.x.org/archives/xorg-driver-ati/attachments/20131026/beddb852/attachment.html>

More information about the xorg-driver-ati mailing list