[Bug 72167] New: radeonsi/KMS: Displayport mode detected incorrectly

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sat Nov 30 00:08:06 PST 2013


          Priority: medium
            Bug ID: 72167
          Assignee: xorg-driver-ati at lists.x.org
           Summary: radeonsi/KMS: Displayport mode detected incorrectly
        QA Contact: xorg-team at lists.x.org
          Severity: normal
    Classification: Unclassified
                OS: Linux (All)
          Reporter: RalfPeter.Rohbeck at quantum.com
          Hardware: x86-64 (AMD64)
            Status: NEW
           Version: unspecified
         Component: Driver/Radeon
           Product: xorg

Created attachment 90013
  --> https://bugs.freedesktop.org/attachment.cgi?id=90013&action=edit

The mode on my (cheap Korean) 1440p monitors on DP outputs (via DP->DVI
converters) is detected incorrectly.
xrandr -q displays
DisplayPort-0 connected 1024x768+2560+0 (normal left inverted right x axis y
axis) 0mm x 0mm
   1024x768       60.0* 
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9  
DisplayPort-1 connected 1024x768+3584+0 (normal left inverted right x axis y
axis) 0mm x 0mm
   1024x768       60.0* 
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9
but since they are single frequency monitors they remain blank.

I can set the correct mode with
xrandr --addmode DisplayPort-0 2560x1440
xrandr --addmode DisplayPort-1 2560x1440
xrandr --output DisplayPort-0 --mode 2560x1440 --output DisplayPort-1 --mode
(details like --rotate and --pos left out) and everything seems to work

This has happened for a while, at least since I started playing around with
radeonsi in March, but it was all hand-built. Now I tried Kubuntu trusty (yay,
radeonsi and glamoregl out of the box) and the issue is still around.

I run 4 monitors on a 7850:
1920x1080 on HDMI (Acer S273HL)
2560x1440 on DVI-0 (Achieva Shimian)
2560x1440 on DP-0 (QNIX QX2700)
2560x1440 on DP-1 (QNIX QX2700)

The HDMI and DVI-0 outputs are handled correctly.

The two monitors on the DisplayPorts are connected via Accell B087B-007B. I had
trouble with the BIOS setting the wrong mode on those two monitors, but since I
updated the firmware on the adapters
(http://www.accellcables.com/displayport-fw-update.html#q4) those problems are
gone. Now everything is correct HW-wise I think.

$ uname -a
Linux ws 3.12.0-4-generic #12-Ubuntu SMP Tue Nov 26 22:38:40 UTC 2013 x86_64
x86_64 x86_64 GNU/Linux
$ cat /etc/lsb-release 
DISTRIB_DESCRIPTION="Ubuntu Trusty Tahr (development branch)"
# dpkg-query -l xserver-xorg-video-radeon \*glamor\*
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                 Version                 Architecture  
ii  libglamor0:amd64                     0.5.1-0ubuntu7          amd64         
         shared graphics acceleration library based on OpenGL
ii  xserver-xorg-glamoregl:amd64         0.5.1-0ubuntu7          amd64         
         X.Org X server -- graphics acceleration module based on OpenGL
ii  xserver-xorg-video-radeon            1:7.2.0-0ubuntu10       amd64         
         X.Org X server -- AMD/ATI Radeon display driver
# cat /proc/cmdline 
root=UUID=f034f2ef-eaad-40af-8530-83f3b4691b6d ro rootflags=subvol=@
drm.debug=4 log_buf_len=10M radeon.dpm=1 sysrq_always_enabled

The attached log files are from the running system, without setting the monitor
modes manually.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.x.org/archives/xorg-driver-ati/attachments/20131130/82333c81/attachment.html>

More information about the xorg-driver-ati mailing list