[Bug 67767] New: no HDMI audio, no display with radeon.audio=1

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sun Aug 4 22:48:35 PDT 2013


          Priority: medium
            Bug ID: 67767
          Assignee: xorg-driver-ati at lists.x.org
           Summary: no HDMI audio, no display with radeon.audio=1
        QA Contact: xorg-team at lists.x.org
          Severity: major
    Classification: Unclassified
                OS: Linux (All)
          Reporter: willem at van.asperen.org
          Hardware: x86-64 (AMD64)
            Status: NEW
           Version: unspecified
         Component: Driver/Radeon
           Product: xorg

I am running Archlinux (kernel 3.10.3) with ati driver 1:7.1, on an ASRock
E350M1 Mini ITX board that has a Radeon HD 6310 on-board. (From the evergreen
family, feature matrix shows "DONE" at HDMI audio). Further specs:

processor: AMD Fusion E-350
chipset: AMD A50M (Hudson-M1)

Attached to the board is my TV set, via HDMI.

Vanilla install works fine, except: no audio via HDMI.

The standard alsa device is configured as card 0, device 0. But poking around
(aplay -l, cat /proc/asound/cards) shows me this should be card 0, device 3.
That's something that needs fixing. But

mplayer -ao alsa:device=hw=0.3 <some file>

returns no errors but I hear no sound...

Reading the (excellent) arch wiki
(https://wiki.archlinux.org/index.php/Radeon#HDMI_audio) I was recommended to
add radeon.audio=1 to my kernel parameters. Without it, I see that I
/sys/.../parameters/audio = 0. Setting the kernel parameter does flip this
parameter into 1...

But: as soon as the kernel loads with this parameter set, the screen goes blank
with no signal detected by my TV. The system continues booting as per normal.
Logging in through ssh and trying to play the same audio file: still no sound
from my TV set. Switching the TV off and back on or unplugging and plugging
back in (all this while mplayer runs), still no sound.

Just for fun: also setting radeon.tv=0 as kernel parameter does not help. Same

When I run mplayer, nothing awkward shows up in journalctl -f

Any clue as to what to try next?

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.x.org/archives/xorg-driver-ati/attachments/20130805/048080e7/attachment.html>

More information about the xorg-driver-ati mailing list